"System Extension Cannot be Used"?

Discussion in 'OS X Mavericks (10.9)' started by Rhobes, Sep 10, 2014.

  1. Rhobes, Sep 10, 2014
    Last edited: Sep 10, 2014

    Rhobes macrumors 6502

    Rhobes

    Joined:
    Oct 28, 2004
    Location:
    Bigfork, MT
    #1
    I just did an update to iTunes v11.4, it installed but when the update was over I got a pop up window (Yellow triangle w/ exclamation point) titled:

    System extension cannot be used
    The system extension “//System/Library/Extensions/AppleUSBEthernetHost.kext” was installed improperly and cannot be used. Please try reinstalling it, or contact the product’s vendor for an update.

    I went to my Library Folder --->Extensions Folder to see this:

    Extensions
    ArcMSR.kext
    ATTOCelerityFC8.kext
    ATTOExpressSASHBA2.kext
    ATTOExpressSASRAID2.kext
    CalDigitHDProDrv.kext
    EPSONUSBPrintClass.kext
    HighPointIOP.kext
    HighPointRR.kext
    PromiseSTEX.kext
    SoftRAID.kext

    I would think it's related to the new iTunes update, but that seems to be done & no indication to re upload that. I don't understand how to reinstall it and who is the products vendor?

    I don't see the "AppleUSBEthernetHost.kext" extension in the Extensions library to begin with. Or, do I just copy it and paste it there?

    TIA
    Rhobes

    EDIT::
    -----------------------------
    I can't believe I'm the only one on this forum with a mac who has downloaded the update to iTunes (11.4) and had this problem. I have surfed a number of other mac forums and this is the "Hot" issue of the day! This is on Apple support but of course ignored with no advise as what to do.

    Really, no one here has had this problem? Wow! Guess this isn't the forum to ask help on...
     
  2. Rhobes thread starter macrumors 6502

    Rhobes

    Joined:
    Oct 28, 2004
    Location:
    Bigfork, MT
    #2
    Hello All-

    I had the AppleUSBEthernetHost.kext problem when downloading iTunes 11.4. This is a widespread problem, many forums have addressed it.

    I found help here: https://www.discussions.apple.com/message/26574841#26574841

    See Lanny’s post, I did as he suggested.
    1st- Close iTunes.
    2nd- Delete the system extension “AppleUSBethernetHost.kext” from here:
    //System/Library/Extensions/AppleUSBethernetHost.kext

    3rd- go to iTunes 11.4 download, here: https://www.apple.com/itunes/download/
    click on the Download Now link.

    4th- Find the downloaded iTunes11.4.dmg file, open it, now open the Install iTunes.pkg

    After the re-install as above I got the successfully installed window and no “pop up”
    improperly installed AppleUSBMultitouch.kext warning window.
     
  3. Doctor Q Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #3
    I had the same problem on an older Mac with Mountain Lion, and the same solution worked.
     
  4. madrich, Sep 18, 2014
    Last edited: Sep 19, 2014

    madrich macrumors regular

    madrich

    Joined:
    Feb 19, 2012
    Location:
    World Class City of Chicago
    #4
    FYI: I had the same problem on my MBP early 2008 with Snow Leopard. I followed Lanny's post and it is now fixed. Thank you!
     
  5. Bigdogorl macrumors newbie

    Joined:
    Sep 19, 2014
    #5
    I can't find this extension either - how do I get there? Or run a search?

    Macbookpro/software/extensions and nothing their related to the error. It's making my transition to the i6+ a serious pain.
     
  6. RubyLee macrumors newbie

    Joined:
    Oct 2, 2014
    #6
    Same exact issue

    I'm having the same issue! Have you found a solution yet? Everyone suggests an iTunes update but I'm already on 11.4!


     
  7. Bigdogorl macrumors newbie

    Joined:
    Sep 19, 2014
    #7
    Had to download the new OS, Mavericks, onto the MacBook and then all was good. I think it's related to the new cloud driver option with iOS 8. They must, I'm assuming, have had to use non native code to get some of he Windows driver like features and it just doesn't work with the last OS.
     
  8. dkgee macrumors newbie

    Joined:
    Aug 3, 2010
    Location:
    Park City UT
    #8
    Be sure you are in the correct Library folder

    When searching for the "AppleUSBEthernetHost.kext" extension, be sure you are looking in the correct Library. The problem file is in the "System/Library/" folder, not the root Library or the User Library.
     
  9. Rhobes thread starter macrumors 6502

    Rhobes

    Joined:
    Oct 28, 2004
    Location:
    Bigfork, MT
    #9
    That is correct, I had the wrong library. Just trashed/deleted the .kext, emptied trash and reloaded iTunes v11.4. This corrects the issue for most.
     
  10. vdonahue macrumors newbie

    Joined:
    Oct 3, 2014
    #10
    What about us poor souls running 10.9? They have hidden the library now.
     
  11. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #11
    Macintosh HD/System/Library is not hidden in Mavericks.
     
  12. vdonahue macrumors newbie

    Joined:
    Oct 3, 2014
    #12

    Ok, finally found it in mine. My husband has messed up his computer big time, and I had a very hard time finding it in his. It would not come up in search. Thanks. I'm just very used to seeing it in the side index as it used to be.

    I did manage to download iTunes from Apple and fix it that way, without having to find the library and just overwrote it.
     
  13. bettybaby00 macrumors newbie

    Joined:
    Oct 7, 2014
    #13
    worked like a charm! Thank you.
     
  14. shambles22 macrumors newbie

    Joined:
    Oct 8, 2014
    #14
    I received the same message after updating iTunes

    There were a couple of other updates that happened at the same time - namely latest Maverick update. I have a early 2011 MacBook Pro 15".
     

Share This Page