System install problem on G5

Discussion in 'PowerPC Macs' started by promoose, Sep 6, 2009.

  1. promoose macrumors newbie

    Jun 18, 2009
    I am having trouble installing the system on my G5. I recently wiped the drive in my MaPro running 10.6, and now both the system restore disk and an OSX 10.4 installer are refusing to let me install, reporting simply that the system cannot be installed in the drive. SMART status is fine, and the disk utility reports no problems. Any ideas?

    The machine is a G5, 1.8 GHz, and the hard drive is the OEM drive.
  2. rtrt macrumors 6502a

    Jan 19, 2008
    this is confusing - a G5 is not a Mac Pro.

    You cant install 10.6 on a G5 but you can on a Mac Pro.

    Does that help?
  3. promoose thread starter macrumors newbie

    Jun 18, 2009
    No, what I did was put the drive in my Mac Pro, wiped it, then put it into my G5 and tried to install the system software.
  4. 4JNA macrumors 68000


    Feb 8, 2006
    looking for trash files
    Intel vs. PPC

    putting the drive in the newer system, i bet that it got a GUID partion instead of the older (and needed for PPC) Apple Partition Map.

    you could check by booting the G5 from the install media, go to Disk Utility and select the drive in the left pane. at the bottom it will show the info about the selected drive, and you are looking for the 'Partition Scheme'.

    if it says 'GUID' then you need to click on the 'partition' tab, and then select the 'options' button at the bottom and check 'Apple Partition Map' and create the new partition (or multiple) with the correct partition scheme.

    if it say 'Apple Partition Map', then you are on your own... no idea. best of luck.
  5. California macrumors 68040


    Aug 21, 2004
    stick the disc in your G5 and pop the install disc in the G5 and turn it on.

    Why would you bother risking having an Intel Mac formatting... just use the G5 through disc utility.
  6. promoose thread starter macrumors newbie

    Jun 18, 2009
    Well, for whatever bizarre reason, I tried it again, and 10.4 installed just fine. Go figure.

    Thanks for your help, anyway.

Share This Page