System installation issues on multiple machines: "An error occurred..."

Discussion in 'Apple Collectors' started by mac1984user, Mar 4, 2015.

  1. mac1984user macrumors 6502a

    mac1984user

    Joined:
    Dec 10, 2009
    Location:
    United Kingdom
    #1
    I am having an issue getting an operating system to install on two old Macs, an LC 475 and a Performa 630. No matter what manner in which I try to install System 7.5.3, I get an error at some stage during the install. The exact same disks worked with my LC III, but not my LC 475 or Performa 630. I will be going about my business and swapping disks in and out and suddenly (and at different stages each time), I'll be asked to "Please insert the disk: Install Disk 1". If I do that, it closes out the install and it says the following:

    "An error occurred while trying to complete the installation. Installation was canceled, leaving your disk untouched."

    So, thinking it could possibly be my floppy disks (though unlikely, since the same ones worked on the LC III), I used another copy of the System 7.5.3 install disks and moved them over to my Floppy Emu. I have the exact same problem. And as I say, this happens with both my LC 475 and Performa 630. They have different hard drives installed and each of them had working OS's prior to my attempts to wipe the drives and put fresh installations of 7.5.3 on. It's worth noting that I have an original copy of System 7.6 that I must have gotten while my mom was still working in education; I've tried those disks and had the same result. I have initialised the drives, tried partitioning the drives, repairing the drives, etc. etc. It seems that no matter what I try to get an OS onto either of these machines, I hit this stumbling block. One more point to add: my LC III has a SCSI2SD adapter with SD card, whereas the 630 and LC 475 have standard SCSI hard drives. Does anyone have any ideas as to what might be causing this and what steps I might take to solve it? Thanks!
     
  2. MacTech68 macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #2
    Most often the solution offered is "your disk is corrupted, get another copy".

    Checking on the installer Application's error messages, it states:

    The System file itself contains "resources" and the installer is adding & removing "resources" to and from that file, hence the Res(ource)Error. (I hope).

    Try booting the install 1 disk while holding down the shift key (usually not required if the install disk is 'clean'). Alternatively, check that the Install 1 disk (the one it boots from) has NO third party extensions or control panels.

    There is also a way to get the installer to install a clean system even if one already exists. When the installer window opens, simultaneously press "Shift" "Apple" "K" and a box will appear asking if you want to "Update Existing System Folder" or "Install New System Folder". Select Install New.

    If that works, look for a folder called "Previous System Folder". It could be anywhere. If you have initialized the drive there should be no reason to keep it.

    And finally, it's just possible that the floppy drives are having trouble reading the disks, or, the disk images you have are corrupted somehow, especially if you made the FloppyEmu images from the floppies. It happens. Heads on floppy drives are constantly wearing out the floppy disk read surface.

    Where did the images on the FloppyEmu come from?

    Another tidbit, look on the HD for a folder called "Installer Temp". That usually is all the stuff it was GOING to remove (if any), up until the error occurred.

    I realize that you started from an erased hard drive, but I'm pretty sure each subsequent time you try, the installer will leave that folder behind. This problem then compounds as it may see that folder as a valid/blessed 'System Folder' and attempt to install into it, revisiting the error over and over.

    Another tip might be to remove as much memory as you can, or swap OTHER memory into the machine (NOT FROM ONE OF THE FAILING MACHINES). :eek:

    Sorry for the long post. Knowing my luck, none of that will work. The only other thing that strikes me is that both macs are 68040 machines. :eek:
     

Share This Page