System network proxy settings don't seem to affect all programs

Discussion in 'MacBook Pro' started by l0uismustdie, Sep 27, 2011.

  1. l0uismustdie, Sep 27, 2011
    Last edited: Sep 28, 2011

    l0uismustdie macrumors regular

    l0uismustdie

    Joined:
    Nov 30, 2009
    Location:
    Edinburgh, UK
    #1
    Hello, I am required to run through a proxy server when connected from my University campus. I have changed the system wide network settings (in system preferences -> networks) but this change only seems to affect some applications. More specifically, it doesn't seem to affect: Firefox, Mail, python (via mechanize), and ssh and does seem to work for: Safari, Chrome, and Skype. Since, it works for Skype which connects over port 56158 I don't think the University has restricted only port 80 access through the proxy.

    I have read a number of similar posts about Mail and proxy but doesn't seem like I could find any answers.

    Thanks.
     
  2. l0uismustdie thread starter macrumors regular

    l0uismustdie

    Joined:
    Nov 30, 2009
    Location:
    Edinburgh, UK
    #2
    So, I've found a working solution to this problem which is bypass the proxy settings altogether and connect to the university's vpn. Hope that helps someone.
     
  3. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #3
    Not all programs honor the system-wide settings. Firefox, for example, doesn't, and any command line programs almost certainly will not.
     

Share This Page