system preference

Discussion in 'MacBook Pro' started by arfofoto, Oct 7, 2008.

  1. arfofoto macrumors newbie

    Joined:
    Aug 23, 2007
    #1
    When i want to open network in system preferences i always get the message "network is changed by an other program". If i say ok the message is always coming back and i have to use force stop. What should i do?

    Thx dirk
     
  2. mahoneyjoe macrumors newbie

    Joined:
    Oct 24, 2007
    #2
    A Newbie Response--proceed with caution

    Hopefully you get another more experienced response because I don't really understand this, but for what its worth, I had this too just this past week and got help with my applecare/calling support.
    Running 10.4.11 on pb15, the support guy had me log into a second account and try opening system preferences, and network, and with that the slip message that you/I got did not show up.
    From that he had me go mac hd>library>preferences>SystemComfiguration then drag the last folder to the desktop, then reboot. My understanding is that upon rebooting, systemconfiguration preferences is then regenerated from scratch, which solved the problem, and I could/did trash the old folder. Now all is good.
    Maybe someone can explain the whats and whys.
    Hope this helps, or leads to further research. Good luck.
     
  3. arfofoto thread starter macrumors newbie

    Joined:
    Aug 23, 2007
  4. mahoneyjoe macrumors newbie

    Joined:
    Oct 24, 2007
    #4
    Great; you're very welcome; I think my first time helping someone. I'd still appreciate an explanation if anyone knows how this works, the trashing of a preferences folder fixing something.
     
  5. rolex54 macrumors 6502

    Joined:
    Aug 20, 2007
    Location:
    Houston, TX
    #5
    you were right, moving the preferences file creates a new one when you restart, often fixing the problem
     
  6. applefan69 macrumors 6502a

    applefan69

    Joined:
    Oct 9, 2007
    Location:
    Medicine Hat
    #6
    OS X saves the preferences you "prefer" in data files... the name of them completely escapes me right now... uhh i think its XML files but idk.

    Anyways, so as you change your preferences, OS X will write your changes to that preference file. Then when OS X needs to know what your preferences you chose are, it'll read that file. (pretty simpy ehh?)

    Well if those files arent in the correct directory, OS X will make new one, with DEFAULT preferences. So by moving that folder from the correct directory then OS X thought those preferences were missing, as a result it just made new preference files set at default settings.

    Why this fixed things, is more then likely because your preferfence file became corrupt, so by making OS X create a new one, problem was solved
     
  7. moonbeam macrumors newbie

    Joined:
    Jan 20, 2008
    #7
    a simple fix that worked for me...

    i found this solution via the comments on a post at urbantektonic.com, it's simple and it worked -

    ...open System Preferences, go to the “security” icon, then click “Require Password to unlock each secure system preference”

    when you open the network pref's the dialogue box should no longer pop up.
     

Share This Page