System Preferences continues to quit unexpectedly!

Discussion in 'Mac Basics and Help' started by pepperboy93, Aug 8, 2008.

  1. pepperboy93 macrumors newbie

    Joined:
    Aug 8, 2008
    #1
    My macbook (not pro, currently running OSX 10.4.11) had been working fine for a while until about a month ago . I was out of town without my computer so I didnt address the problem until now. Neither my volume or brightness control keys work by using the F1-F5 buttons. I had a similar problem once before, but this was fixed by system preferences. When I open system preferences it is fine. However, whenever I click on Security, Displays, Mouse and Keyboard, or Sound, it "quits unexpectedly". All the other options to click on in system preferences work just fine. I think this came about when I tried to reinstall frontrow a while ago. For this I downloaded something called Pacifist and the fontrow update, as this is what I heard I needed to do. However, I have deleted both of these downloads and the problem still continues. Please If anyone could help I would greatly appreciate it.
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    The System Preferences caches are probably corrupt. You can fix this by going into your user folder -> Library -> Caches and deleting stuff with System Preferences or systempreferences in its name. Also, go to Macintosh HD -> Library -> Caches and do the same thing.
     
  3. pepperboy93 thread starter macrumors newbie

    Joined:
    Aug 8, 2008
    #3
    thank you for the advice. i tried this and it didnt work, so i cleared all the caches I thought could possiby be related as well as a few others and still no progress. THnk you though
     
  4. ZaneVeritas macrumors newbie

    Joined:
    Nov 3, 2008
    #4
    It Worked!

    Hey I just thought I'd let everyone know that deleting those files worked!! I had to delete a few of them but after I did it worked right away. Thank you thank you.
     

Share This Page