System Preferences -> Desktop is kind of broken

Discussion in 'OS X Mountain Lion (10.8)' started by MyFakeAcc, Oct 6, 2012.

  1. MyFakeAcc, Oct 6, 2012
    Last edited: Oct 6, 2012

    MyFakeAcc macrumors newbie

    May 6, 2011
    I got some problems. Before upgrading to 10.8 I added two folders (let's say A and B). These folders are now not removable for me. I click the "-" and they disappear but once System Preferences is relaunched they are present again.

    System Preferences[707]: Could not restore selection, using default folder
    Is listed in for every time I remove A or B.

    I already deleted the corresponding .plists:

    But after a restart of Sys Prefs the files reappear - with entries for folder A and B! There has to be some default setting for SysPrefs but I don't know where. Even editing the plist files directly and changing the values will be ignored. Adding a new folder works but only the last one added persists (others disappear).

    I tried starting System Preferences as root for the case there would be some missing write permissions but without success. I got no clue what to do next. :/

    Whenever I change ~/Library/Preferences/ it will be overriden when System preferences is relaunched. Removing rw permissions for everyone editing the .plist by hand does not help, too. The changes will be ignored.
  2. MyFakeAcc thread starter macrumors newbie

    May 6, 2011
    Seems like I was able to track down the problem but still no fix.
    Whenever I change some folders in 'Desktop' preferences those changes apply to a record '0' in (Root -> Background -> spaces -> 0) while the values are loaded from records '458607821' and '722488972' (my two attached displays). Console logs the following:
    07.10.12 13:16:32,810 Dock[340]: DesktopPicture: sent notification for space  and display 0x0 that does not exist
    So the changes are applied to the wrong record.

    I plugged in/out my displays multiple times as well as rearranged them but still no luck.

Share This Page