System Preferences Freeze

Discussion in 'Mac Basics and Help' started by pgmeyer, Dec 28, 2007.

  1. pgmeyer macrumors newbie

    Joined:
    Dec 28, 2007
    #1
    Hi,
    I am having a problem with System Preferences freezing up when selecting Desktop & Screen Saver. Everything else on the system works fine.

    I loaded a picture on the Macintosh HD Device (all other pictures are under a specific user account) to access it as a desktop background. The correct picture appears as the desktop background, but I want to change the picture. As soon as I select Desktop & Screen Saver under System Preferences the window freezes.
    The only way to unfreeze is to select something else on the Dock (which doesn't magnify as it normally does), then close that and go to back to System Preference and then close it. Or select something else from the dock and then Force Quit the Systems Preferences.

    I will get an error message and the problem details (which I know VERY little about) show an Exception Type: EXC_BAD_ACCESS (SIGSEGV) and
    Exception Code: KERN_INVALID_ADDRESS
    If that helps.

    I tried sending the picture to the trash and then reloading it, but that didn't help either.

    Any ideas on how to get back the the default or fix this problem are greatly appreciated.
    Thank you!

    iMac 2Ghz 2 Duo upgraded to 10.5.1
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Try dragging the following items out of your Preferences folder, and then restart.


    • com.apple.systempreferences.plist
    • com.apple.desktop.plist
     
  3. pgmeyer thread starter macrumors newbie

    Joined:
    Dec 28, 2007
    #3
    mad jew,
    Thanks for the reply. That fixed the problem and everything appears back to normal. I appreciate your help.
    Thanks again.
     
  4. IMcD23 macrumors regular

    IMcD23

    Joined:
    Aug 4, 2007
    Location:
    Iowa, United States, Earth, Milky Way, . . .
    #4
    I had the same problem here I will try this.

    EDIT: It didn't work
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    Try removing a file named com.apple.screensaver.XXX.plist where XXX represents a series of numbers, and then restart.
     
  6. CharlieB1 macrumors newbie

    Joined:
    Mar 29, 2010
    #6
    Can anybody help??

    I am having the same problem when I click on the accounts on system preferences what should I do?
     
  7. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #7
    You should do the same things suggested above.

    If you have, and they didn't help, you have to say so.
     
  8. CharlieB1 macrumors newbie

    Joined:
    Mar 29, 2010
    #8
    I have tried what was mentioned above but the solution above seems to be to when The screensaver desktop pane freezes, I do not have that case what freezes is the Accounts in system pref pane.
     
  9. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #9
    This one would be general for all panes in System Preferences. There are not a specific ones for the various panes. You did this one too?

    If still not working, the next thing to try would normally be to log in under a different user account. But, as you're having problems with the pane where you control accounts, that could be a challenge.

    Maybe someone else knows a work-around.... Help!

    The next, more drastic step would be to reinstall the OS.
     
  10. CharlieB1 macrumors newbie

    Joined:
    Mar 29, 2010
    #10
    I have tried the plist thing and another user has recommend for me to reinstall System Preferences through my mac install cd and Pacifist do you consider this option viable? without causing any harddrive damage?
     
  11. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #11
    There's no potential for hard drive damage. You could do a full archive and install of the OS if you don't have Pacifist.
     
  12. CharlieB1 macrumors newbie

    Joined:
    Mar 29, 2010
    #12
    Lol I tried the Pacifist thing and still the same would you like me to post the error thread that appears so you can see if you can find a solution??
     
  13. butterscotch macrumors newbie

    Joined:
    Aug 7, 2009
    #13
    this was happening to me today and I just had to wait a few minutes for the system to recognize my entire iphoto program before I was able to move on and do anything else with it.

    Mine only froze when I clicked on the screensaver side of the window. I was worried that I had lost the option to use my own pictures, but once everything loaded it was fine.
     
  14. CharlieB1 macrumors newbie

    Joined:
    Mar 29, 2010
    #14
    The thing is when I click on the Accounts pane it freezes and then the error comes up and even when I click the error poops up , now when I sign in in the login screen the guest account appears but when I click on it it shakes and wont let me enter through the guest account it all happened when I configured my pc -mac shared network I guess would you like me to post the error thread?
     
  15. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #15
    Charlie, the error message might shed some light on it for someone here. Go ahead and post it.
     
  16. CharlieB1 macrumors newbie

    Joined:
    Mar 29, 2010
    #16
    Error

    Process: System Preferences [196]
    Path: /Applications/System Preferences.app/Contents/MacOS/System Preferences
    Identifier: com.apple.systempreferences
    Version: 7.0 (7.0)
    Build Info: SystemPrefsApp-1750100~6
    Code Type: X86-64 (Native)
    Parent Process: launchd [116]

    Date/Time: 2010-03-31 08:43:38.340 -0600
    OS Version: Mac OS X 10.6.3 (10D573)
    Report Version: 6

    Interval Since Last Report: 55992 sec
    Crashes Since Last Report: 5
    Per-App Interval Since Last Report: 521 sec
    Per-App Crashes Since Last Report: 5
    Anonymous UUID: 84B9A4BE-4F17-40A5-94C3-F12DCE667DD1

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000116b17860
    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Application Specific Information:
    objc_msgSend() selector name: willSelect
    objc[196]: garbage collection is ON

    Thread 0 Crashed: Dispatch queue: com.apple.main-thread
    0 libobjc.A.dylib 0x00007fff8452511c objc_msgSend + 40
    1 com.apple.systempreferences 0x0000000100008426 0x100000000 + 33830
    2 com.apple.systempreferences 0x0000000100006fb8 0x100000000 + 28600
    3 com.apple.Foundation 0x00007fff87036448 __NSFireDelayedPerform + 404
    4 com.apple.CoreFoundation 0x00007fff88762708 __CFRunLoopRun + 6488
    5 com.apple.CoreFoundation 0x00007fff887608df CFRunLoopRunSpecific + 575
    6 com.apple.HIToolbox 0x00007fff83be4ada RunCurrentEventLoopInMode + 333
    7 com.apple.HIToolbox 0x00007fff83be483d ReceiveNextEventCommon + 148
    8 com.apple.HIToolbox 0x00007fff83be4798 BlockUntilNextEventMatchingListInMode + 59
    9 com.apple.AppKit 0x00007fff87adba2a _DPSNextEvent + 708
    10 com.apple.AppKit 0x00007fff87adb379 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 155
    11 com.apple.AppKit 0x00007fff87aa105b -[NSApplication run] + 395
    12 com.apple.AppKit 0x00007fff87a99d7c NSApplicationMain + 364
    13 com.apple.systempreferences 0x0000000100001cf4 0x100000000 + 7412

    Thread 1:
    0 libSystem.B.dylib 0x00007fff824bf30a __workq_kernreturn + 10
    1 libSystem.B.dylib 0x00007fff824bf71c _pthread_wqthread + 917
    2 libSystem.B.dylib 0x00007fff824bf385 start_wqthread + 13

    Thread 2: Dispatch queue: com.apple.libdispatch-manager
    0 libSystem.B.dylib 0x00007fff824be4ea kevent + 10
    1 libSystem.B.dylib 0x00007fff824c03bd _dispatch_mgr_invoke + 154
    2 libSystem.B.dylib 0x00007fff824c0094 _dispatch_queue_invoke + 185
    3 libSystem.B.dylib 0x00007fff824bfbbe _dispatch_worker_thread2 + 252
    4 libSystem.B.dylib 0x00007fff824bf4e8 _pthread_wqthread + 353
    5 libSystem.B.dylib 0x00007fff824bf385 start_wqthread + 13

    Thread 3:
    0 libSystem.B.dylib 0x00007fff824bf30a __workq_kernreturn + 10
    1 libSystem.B.dylib 0x00007fff824bf71c _pthread_wqthread + 917
    2 libSystem.B.dylib 0x00007fff824bf385 start_wqthread + 13

    Thread 4:
    0 libSystem.B.dylib 0x00007fff824e0316 __semwait_signal + 10
    1 libSystem.B.dylib 0x00007fff824e01a5 nanosleep + 148
    2 libSystem.B.dylib 0x00007fff8252d0a4 sleep + 61
    3 ??? 0x0000000116ac6947 0 + 4675365191
    4 libSystem.B.dylib 0x00007fff824e1610 _dispatch_call_block_and_release + 15
    5 libSystem.B.dylib 0x00007fff824c01b2 _dispatch_queue_drain + 251
    6 libSystem.B.dylib 0x00007fff824c0014 _dispatch_queue_invoke + 57
    7 libSystem.B.dylib 0x00007fff824bfbbe _dispatch_worker_thread2 + 252
    8 libSystem.B.dylib 0x00007fff824bf4e8 _pthread_wqthread + 353
    9 libSystem.B.dylib 0x00007fff824bf385 start_wqthread + 13

    Thread 0 crashed with X86 Thread State (64-bit):
    rax: 0x0000000000000001 rbx: 0x0000000200053ee0 rcx: 0x00000002000c7b51 rdx: 0x00007fff5fbfe2e0
    rdi: 0x00000002004685c0 rsi: 0x00007fff80c9e8a4 rbp: 0x00007fff5fbfe7f0 rsp: 0x00007fff5fbfe5b8
    r8: 0x0000000000000008 r9: 0x0000000000000000 r10: 0x0000000000000001 r11: 0x0000000116b17850
    r12: 0x0000000000000002 r13: 0x00000002004685c0 r14: 0x000000020009fe60 r15: 0x0000000200055020
    rip: 0x00007fff8452511c rfl: 0x0000000000010206 cr2: 0x0000000116b17860
     
  17. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #17
    That's curious! Since replacing the systempreferences.plist file didn't help, and Pacifist didn't help, you probably are left with reinstalling the OS as a last resort. I'd recommend an archive and install, which will not delete your files.
     
  18. MarshallXDTeach macrumors newbie

    MarshallXDTeach

    Joined:
    Apr 15, 2010
    Location:
    In your mother's dreams :)
    #18
    This thread did shed some light, but I still have this problem that is bugging me real bad. Can anyone help me?

    EDIT: I got it fixed somehow, thanks anyway.
     

Share This Page