System Preferences Freezes when I choose Network

Discussion in 'Mac Basics and Help' started by ANewMacGuy, Apr 1, 2009.

  1. ANewMacGuy macrumors newbie

    Joined:
    Jan 15, 2008
    #1
    Hi All,
    Been a rough two weeks. I had the issue of my iMac not loading passed the grey screen. No keystrokes were working so I had to bring it in to get repaired. I was told some optic something cable had to be replaced.

    Well, initially that didn't work but it just ended up taking forever too boot. 20 or 30 minutes. Now it is loading fine and Windows is also loading fine with bootcamp.

    However, I can't get in to turn on my USB wireless adaptor for Sprint. I can open the system preferences and I can also go in to any other option without problems, but if I click "Network" it says Loading Network, then hangs up. I need to force quit and retry. Same results. Anyone know how to repair that? I have tried Disk Utility and it says no problems. Diskwarrior doesn't let me do much since I am booted to that drive. Any suggestions as to how to get the Network option to open?

    ANewMacGuy
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Delete the preferences.plist under Library/Preferences/System Congiguration/.
    That will reset all your network locations.

    Does that help?
     
  3. ravenvii macrumors 604

    ravenvii

    Joined:
    Mar 17, 2004
    Location:
    Melenkurion Skyweir
    #3
    Oooh man, a worm called Conficker doesn't want you to futz with the network settings!

    Have fun with that.............

    Yes, April's.
     
  4. ANewMacGuy thread starter macrumors newbie

    Joined:
    Jan 15, 2008
    #4
    Hi,

    Thanks for the suggestion. I followed that path and I do not have that file. Any suggestions where to find it or add it back in there?

    I did find it. Removed that file plus a few more that another forum suggested, rebooted, still locking up when I click Network.

    ANewMacGuy
     
  5. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #5
    What about looking into the Network settings while this USB Wireless Sprint thingy isn't connected to your Mac?

    Does it still lock up the System Preferences?
     
  6. ANewMacGuy thread starter macrumors newbie

    Joined:
    Jan 15, 2008
    #6
    Thanks for the suggestions. I had to do a Archive and Install and that fixed my problem. Probably was an easier way but I needed my iMac working.

    I will do a search now but was wondering, is there a way to get the keychain that had all my sites/passwords from the old system to the current one? If so, not sure which one is the right one. I think there were 4 in that folder.
     
  7. Morod macrumors 68000

    Morod

    Joined:
    Jan 1, 2008
    Location:
    On The Nickel, over there....
    #7
    Do you have a backup drive? Are you using Time Machine? You should be able to go back in there and locate the Keychain.
    Morod
     
  8. ANewMacGuy thread starter macrumors newbie

    Joined:
    Jan 15, 2008
    #8
    Yes, I have a 1 TB drive but can't get time machine to go past, Preparing drive or something like that.

    Aside from that, I was hoping the Archive feature was going to copy my system files for a reason like this. Just not sure which file I need.

    ANewMacGuy
     

Share This Page