System Preferences hanging in Snow Leopard

Discussion in 'macOS' started by richard.mac, Sep 6, 2009.

  1. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #1
    my System Preferences sometimes hangs when i open it in Snow Leopard and i have to force quit it and then reopen to use it properly.

    trashing its cache seems to relieve it temporarily but it soon starts to happen again and ive tried trashing its preferences file.

    is anyone getting this problem? is there a fix? ive tried reinstalling System Preferences but no luck.
     
  2. richard.mac thread starter macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    happening a lot less now for some reason, but still happening. ruled out third party .prefpane incompatibilities.

    just wondering if anyone else is getting this. i didnt have it after an upgrade, but started happening after i did a clean install.
     
  3. ogmc macrumors newbie

    Joined:
    Sep 13, 2009
    Location:
    Auckland, NZ
    #3
    yup.

    I'm having this issue too.
    But for me it's not just limited to the system preferences.
    It's happening to everything and happens intermittently.

    It's made me boot my MBP into W7 and now looking at selling my MBP off, cos I know people who've brought laptops that are cheaper than my MBP and these laptops run W7 faster than my MBP (which is not a surprise, as the HW in their machine is higher spec'd than my MBP).

    Good luck with trying to find out what the cause of it is - I've spent like 2 days deleting/reinstalling all my apps and even SL itself, but no luck.

    O.
     
  4. mitnworb macrumors newbie

    Joined:
    Sep 22, 2009
    #4
    I have the same problem.

    It seams to clear itself up after I remove software, but then comes back after a reboot or two. I thought I had it narrowed down to 1Password, but the it started happening again. I have re-installed SL 3 times now and each time i have the same problems. I suppose I should expect it since I am installing the exact same software (more or less, I keep updating as soon as apps are updated). I have a 2.16 Core Duo MBP. I would love any help. Thanks.

    - Tim
     
  5. GY4Steve macrumors newbie

    Joined:
    Dec 16, 2009
    #5
    Same problem here. Have also done a clean reinstall but problem persists. Have tried trashing plist etc but no further forward. Need some Ninja help to sort this one !
     
  6. Salmar macrumors regular

    Joined:
    Sep 16, 2007
    Location:
    Florida
    #6
    I have a similar problem. When I click on system preferences, trash, software update etc. it always takes a few seconds for them to open up and show themselves. Everything else works okay other than that. As long as they open I can live with it. It may have started with snow leopard but I can't be certain about that because I don't remember.
     
  7. funkfunkitup! macrumors newbie

    Joined:
    Dec 20, 2008

Share This Page