System Preferences "Lock" Question

Discussion in 'macOS' started by MacNewb721, Jul 24, 2008.

  1. MacNewb721 macrumors newbie

    Jul 24, 2008
    As the name indicates, I am a Mac Newb with a basic question. On my MBP, 10.5.4, when I click the lock under both the Security and the Sharing panels of System Preferences ("click lock to prevent future changes") I noticed that, upon restarting, these locks are opened again without me doing so. Also, the lock under the Accounts panel remains locked. Is this normal?
  2. deltaiscain macrumors regular

    Jul 24, 2008
    I have the same problem. I also have it ticked to lock all system preferences panes, but it opens them all, except for Accounts.
  3. MacNewb721 thread starter macrumors newbie

    Jul 24, 2008
    Bump. After restarting my MB, all the panes in System Preferences (except for "Accounts") were unlocked again. I checked the "Require password to unlock each System Preferenes pane" box under "Security", restarted my system, and all the panes remained locked. However, I noticed that under "Security", the "Use secure virtual memory" box was checked (I didn't check it myself).

    Is this normal? Can anyone shed some light on this issue? Did I solve the problem? Should I be concerned? (The only two computers that use our home network are this MB and my g/f's Dell...)
  4. turqmelon macrumors newbie

    Jun 28, 2009
    On the right track

    If you set to keep all preference panes locked, secure virtual memory activates. This is the setting that keeps the panes secure.
  5. larkost macrumors 6502a

    Oct 13, 2007
    I don't believe that this is the case at all. I just enabled "Require a password to unlock..." on my machine and it die not touch secure virtual memory. I don't know where you would get the idea that these two were related.

    Now to some real answers:

    The reason that it would still be unlocked is that by default once you authorize your authorization lasts for a set amount of time (30 seconds I believe, but don't have 10.5 in front of me to check). If you want to change this then the setting is in: /etc/authorization. You are looking for "authenticate-admin*" in rules, and the timeout value in there.

    And secure virtual memory is on on your MacBook Pro because Apple now defaults it to on on all laptops, and off on desktops (makes sense). This changed in one of the security updates, but I don't remember which one.
  6. Tanmay macrumors newbie

    Jul 25, 2011

Share This Page