System Preferences Not Responding OS X Lion

Discussion in 'Mac Basics and Help' started by cloudmonsterr, May 20, 2012.

  1. cloudmonsterr macrumors newbie

    Joined:
    May 20, 2012
    #1
    Hi all Mac Users, anyone knows how to troubleshoot this problem? I opened up my System Preferences for Mac to change my desktop picture, but it keeps hanging, so I opened Console and got the following. I've already restarted the Mac FIVE TIMES, but the same problem persisted. ):
     

    Attached Files:

  2. Damo01 macrumors regular

    Joined:
    Feb 11, 2010
    Location:
    Australia
    #2
    Try the lion recovery assistant or do reinstall of lion. It may do wonders and may fix up the problem you having with system preferences. Backup any important data if needed.
     
  3. MadTester macrumors regular

    MadTester

    Joined:
    Mar 24, 2012
    #3
    Have you tried verifying/repairing permissions through the disk utility? failing that (apart from using the lion recovery). It could be a simple matter of that.

    Hope This Helps :D
     
  4. stomer macrumors 6502a

    Joined:
    Apr 2, 2007
    Location:
    Leeds, UK
    #4
    Have you installed any 3rd party preference panes?

    Look in ~/Library/PreferencePanes and /System/Library/PreferencePanes

    Perhaps move any to a temporary location, reboot then and the, back in one at a time to find out which one is causing the problem.
     
  5. FlatlinerG macrumors 6502a

    FlatlinerG

    Joined:
    Dec 21, 2011
    Location:
    Ontario, Canada
    #5
    Try booting up in safe mode and see if it happens there. If not, then it might be an issue caused by some recent files/apps.

    When did the issue start?
    Have you installed anything new or done anything differently.
     
  6. Max Huang macrumors newbie

    Joined:
    Jun 16, 2012
    #6
    Not working.

    Hi there, I have try to use the disk utility to repair the disk, but it still not working. That's anything that I miss out? Pls help me, thanks:(
     
  7. keithymart40 macrumors newbie

    Joined:
    Dec 29, 2010
    #7
    system preferences frozen

    yesterday I changed my desktop picture successfully but ever since I have not been able to get out of system preferences. It just hangs there like its looking for more pictures in iPhoto. I have tried all the suggestions below apart from a reboot of Lion.

    I have used disk utility to verify disk and repair any problems
    I have removed folders from Library/PreferencePanes and /System/Library/PreferencePanes with no change
    I have deleted iphoto

    There is no difference when booting in safe mode

    Anybody find a solution or got any ideas

    Thanks for help
     
  8. keithymart40 macrumors newbie

    Joined:
    Dec 29, 2010
    #8
    sydtem preference frozen

    problem solved by deleting iPhoto and reloading it :)
     
  9. nyynyj, Jul 18, 2012
    Last edited: Jul 18, 2012

    nyynyj macrumors newbie

    Joined:
    Jul 16, 2012
    #9
    All about iPhoto

    All depends on where you are at in terms of new or established Mac. Mine is fairly new and this all started when I went to change pictures on my monitors. I had not set up Time Machine, so I did not have a good image to revert to.

    I put everything of worth onto an external hard drive, deleted iPhoto, then reinstalled Lion. That did the trick, and I immediately activated Time Machine.

    Today I went to change a picture, it hung, and I just did Command/r on start-up and opted to restore from Time Machine, and used last image from when things worked well.

    All good, albeit annoying. That System Preferences is that vulnerable ,,, or that iPhoto corruption can affect this very essential utility ,,, I think those need to decouple.
     
  10. spaultivarious macrumors newbie

    Joined:
    Jun 4, 2013
    #10
    I just fixed my background pic/system preferences color wheel issue without any uninstall/reinstall headaches.

    Open iPhoto select any picture. Click "Share" tab at the top then "Set Desktop". Done.

    My daughter had set the desktop picture to something she found online. I'm assuming it wasnt something that was saved to our iPhoto. Sys Pref hung up looking through iPhoto for the pic and could never find it.
     

Share This Page