Resolved system preferences opening on startup

Discussion in 'Mac Basics and Help' started by Letterdief, Jun 2, 2014.

  1. Letterdief, Jun 2, 2014
    Last edited: Jun 2, 2014

    Letterdief macrumors newbie

    Joined:
    Mar 23, 2014
    #1
    Hello all,

    Everytime my macbook pro starts, the system preferences open.
    I don't want that. It started yesterday, and I don't know how it did.
    Can anyone help me? I find this annoying!

    [​IMG]

    [​IMG]
     
  2. jakesaunders27 macrumors 6502a

    jakesaunders27

    Joined:
    Jan 23, 2012
    Location:
    United Kingdom
    #2
    Is it open when you shut down your mac? If so whenever OSX boots it opens everything that was open before unless you tell it otherwise.
     
  3. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #3
    Check your login items too. System Preferences --> Users & Groups --> Your account --> Login Items

    If it's in there, click on it and remove it.
     
  4. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #4
    The screen shot (I believe) shows that it's NOT going to open on login, assuming my translation is correct! I believe that also that the dock correlated with the System Prefs login pane.

    If it is unchecked in the System Prefs, it is likely that the plist is corrupt that remembers what to open on 'login' to the systems, I would recommend deleting that from your "~/Library/Preferences/" folder.
     
  5. Letterdief thread starter macrumors newbie

    Joined:
    Mar 23, 2014
    #5
    Yes, you are correct. All my preferences indicate that it should NOT open on login. I will try your solution and let you know if the problem is solved or not.
     
  6. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #6
    Sure, BTW - I believe the file is com.apple.loginwindow.plist (and any lock files), from memory.. It's a bit vague right now. Goodluck!
     
  7. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #7
    Not this one.

    ~/Library/Preferences/com.apple.loginitems.plist

    Trash it, then reboot.
     
  8. Letterdief thread starter macrumors newbie

    Joined:
    Mar 23, 2014
    #8
    I trash it, but I can't empty the trash because it's still in use. Solution?
     
  9. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #9
    Sorry yes I should have been more precise. Thanks

    It'll be fine in the trash, it won't know where to look on login and hopefully recreate the file, after which you can delete. Can you try a reboot now?
     
  10. Letterdief thread starter macrumors newbie

    Joined:
    Mar 23, 2014
    #10
    So for anyone who has this problem in the future:

    1) find ~/Library/Preferences/com.apple.loginitems.plist
    2) Trash file
    3) Restart

    PROBLEM SOLVED!

    Thanks everyone :D
     
  11. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #11
    Glad to hear it!! Happy WWDC day!
     
  12. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #12
    Sounds like it should be made an official holiday!
     
  13. audiking macrumors newbie

    Joined:
    Dec 7, 2014
    Location:
    Chicago
    #13
    Doesn't work for me

    I tried all that you suggested and it does not work for me. System Preferences still appears when I boot up my MacBook Pro running Yosemite. It started a few days BEFORE I upgraded from 10.6.8 to Yosemite (10.10.1).

    Help!
     
  14. audiking macrumors newbie

    Joined:
    Dec 7, 2014
    Location:
    Chicago
    #14
    I figured it out.

    Since System Preferences opened on startup with the BackBlaze pane showing, that told me there was something with that setting. So, I deleted BackBlaze from the Login Preferences and now two things are wonderful:

    1. System Preferences does not open anymore at startup
    2. BackBlaze still shows up in my menu bar.

    The Apple fairies have descended!
     

Share This Page