System preferences problem

Discussion in 'Mac Basics and Help' started by deuce22, Jan 29, 2010.

  1. deuce22 macrumors newbie

    Joined:
    Oct 22, 2009
    #1
    Hi.

    I bought my very first macbook few months ago, so I'm just getting used to how it works.

    I have recently had a problem with the system preferences.

    It shows in the dock with a hazard symbol in front of it, when I try to open it the following appears.

    You can't open the application system preferences because it may be damaged or incomplete.

    Can someone please give me some advice on what to do.

    Thanks.
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Do you get the same message when you try to access it from the  menu?
     
  3. deuce22 thread starter macrumors newbie

    Joined:
    Oct 22, 2009
  4. MacDawg macrumors P6

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #4
    If it were me, I would probably use the restore discs that came with the computer and do an archive and install of the system

    Woof, Woof - Dawg [​IMG]
     
  5. SnapperNZ macrumors newbie

    Joined:
    Jul 17, 2007
    #5
    Assuming you have 10.6 I would download 10.6.2 update and install that first. You may find the update includes a copy of the system preferences.app.

    Failing that, if you can get hold of another mac with the same OS and patch level then copy the system preferences.app off that.

    This is a good reason to look at Time Machine - as you could have simply restored the .app from that.......

    Let us know how you get on.
     
  6. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #6
    I'd drag com.apple.systempreferences.plist out onto the Desktop and then go back into the application. If no change, then Restart. The idea is to let the OS generate a new plist file.

    I'm on Leopard, but your plist file should be similarly located:
    Users/YourUserName/Library/Preferences

    If that doesn't help, go with the more "serious" measures above.
     
  7. s.mahjoob macrumors newbie

    Joined:
    Jan 30, 2010
    #7
    Pacifist

    for solving this issue you can follow these steps:
    1-download Pacifist from internet (trial)
    2-extract contents of installation DVD via Pacifist (open package)
    3-searching for system preferences in search bar
    4-extract System Preferences.app to Application folder
     
  8. SnapperNZ macrumors newbie

    Joined:
    Jul 17, 2007
    #8
    Gregg2's idea of moving the plist is a good and easy thing to try, if you haven't already!

    Last but not least, I could even email you the .app file - reply back here if you want that......
     
  9. debie2401 macrumors newbie

    Joined:
    Feb 18, 2010
    #9
    I am having exactly the same problem and I have tried what has been suggested on here but still no luck. Can anyone send me more information please

    Thanks
    debbie




    Last but not least, I could even email you the .app file - reply back here if you want that......[/QUOTE]
     
  10. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #10
    If deleting the .plist file didn't work, using the install CD as stated in post #7 should have. Did you do that?
     
  11. deuce22 thread starter macrumors newbie

    Joined:
    Oct 22, 2009
    #11
    Thanks very much for all your help.

    I found the original disk that came with the mac and re-installed the applications file again.
     
  12. IndyCarTim macrumors newbie

    Joined:
    Jul 31, 2011
    Location:
    DFW, Texas
    #12
    I purchased a pre-owned MacBook and I did NOT receive the original cds that came with it. I'm getting this error message now. Is there any chance someone can email me the system preferences file for 10.6.7? I REALLY hope so since I'm out of ideas...

    indycartim@gmail.com

    Thanks in advance! Any other suggestions would be helpful too...

    Timm
     

Share This Page