System profiler reporting wrong info -> corrupt firmware??

Discussion in 'Macintosh Computers' started by letaage, Feb 10, 2004.

  1. letaage macrumors newbie

    Feb 10, 2004
    I had problems doing a fresh install of Panther on a friend's Dual 1GHz G4, 768 MB, Superdrive, 60BG HDD (M8667LL/A I believe).

    This box had previously been upgraded from 10.1 to 10.3 but I thought clean install might clear up the occassional problem my friend was having.

    The fresh install did not go smoothly it kept failing before the end of the first CD. I tried everything to get the install to work:

    1) I stripped the system down to bare bones - keyboard and mouse only
    2) I repartitioned the hard disk and rebuilt the partition table
    3) I swapped the Superdrive out for a newer one
    4) I zapped the PRAM
    5) I reset the PMU on the board

    Only after I removed a 512MB PC133 DIMM from the board (that I'd installed months ago and that appeared to be working ok) did Panther install and run. I guess the RAM might have been a bit dodgy...

    But now here's where I dicovered a problem. I put the RAM back in and power it up and I get the 3 power up tones indicating RAM failure. I powered everything down again, checked the RAM was seated properly and powered it up again. This time no fault tones but the extra 512MB of memory isn't recognised by System profiler.

    What's more, I noticed System Profiler is now reporting the computer as a SINGLE CPU 867MHz Power Mac G4, and not a DUAL CPU 1GHz! The "sysctl hw.cpufrequency" command reports 867MHz as does Xbench.

    I tried the openfirmware reset procedure, but it didn't recognise the "reset-nvram" command. I have boot ROM Version 4.23f1.

    I looked at the openfirmware setting last night and at least to me it appeares that the firmware isn't reporting 2 CPUs. I think in my efforts to get Panther to install I might have corrupted the firmware.

    Does anyone know where I can download something to reflash the firmware? I've searched the Apple site and found links to Firmware 4.2.8 update, but when I ran it it says the computer is already up to date.

    Any help is appreciated!
  2. 7on macrumors 601


    Nov 9, 2003
    Dress Rosa
  3. letaage thread starter macrumors newbie

    Feb 10, 2004
    The system is currently running using just the original 256MB it shipped with.

    I have removed the suspect extra memory and the issue is still there, ie the system seems to think it is a single CPU 867MHz G4 and not the dual CPU 1GHz G4 that it is.

    The problem doesn't appear to be related to the RAM.

    Does anyone know of a way I can check the firmware to see if it's been corrupted?

    The only things I haven't tried are:

    1) booting the system off an external drive with a working Panther install - this should clear up whether it's a software or hardware related problem.

    2) removing the system battery and power for a while to wipe the NVRAM.

    Any other ideas?
  4. letaage thread starter macrumors newbie

    Feb 10, 2004
    I tried both the above mentioned options last night.

    Booting off an external HDD yielded the same results, ie the system still thought it was a single CPU 867 MHz G4 and not a sual 1GHz G4.

    I removed the battery and power too. But before that I measured the voltage of the battery on the board. It read 3.1V, which is below the 3.4 to 3.7V it should be as I read on the Apple site.

    I measured the battery again once it was removed and it read 3.6V - indicating a current draw when installed - which is as you'd exptect.

    I replaced the battery in the holder and now it read within spec - indicating a lower current draw, which is a little perplexing.

    I did the whole PMU reset thing and the thing wouldn't boot again, the power light wouldn't stay on . PANIC!

    I found some procedure on the Apple site and it now boots again but after all that messing about the problem still remains....

    Looking more and more like a trip to the Apple store is in order.....
  5. Dont Hurt Me macrumors 603

    Dont Hurt Me

    Dec 21, 2002
    Yahooville S.C.
    Did you check with apple for firmware updates BEFORE upgrading to panther?Did he before going from 10.1 to 10.3? also please tell me you used static precautions
  6. letaage thread starter macrumors newbie

    Feb 10, 2004
    To answer your question, the system was running 10.3 BEFORE the reinstall and software updates did not say there were any firmware upgrades for this device - it's new enough not to need one.

    And re anti static precautions - I'm an electronics engineer so I'm well versed in them!

    But more info:

    To test a theory, I got hold of a brand new memory card from Crucial and tried that out - the Mac identified it correctly, it now thinks it has 768MB instead of just 256MB. I'm using it to type this message.

    As a secondary test, I tried putting the suspec DRAM back in, the one that the system had failed to recognise previously, and voila up the system came now sporting a grand total of 1.25GB!

    It still shows it being the single cpu 867MHz G4 so all is not solved - but my friend will be happy with the extra memory once I sort out the CPU problem...
  7. Calliander macrumors member

    Jan 7, 2004
    Long Beach, CA
    Sounds like Logic board. I would bring it to an Apple Store or a local Reseller. :)

Share This Page