System sounds playing through external microphone

Discussion in 'MacBook' started by kieran1111, Mar 29, 2017.

  1. kieran1111 macrumors newbie

    Joined:
    Mar 29, 2017
    #1
    This problem is nearly five years old and I've yet to find a single solution.

    I'm using a 2015 macbook air but the problem occurs on older macbooks as well.

    My system sounds (eg. youtube videos, other people's voices if I'm in a skype/etc. call) are being played through my built-in microphone. Other people can hear videos I watch, and their own voices, which are also being played much louder than my own voice. As a result, I cannot use the built in mic to voice chat because it makes it unbearable for the other person.

    I can't find anything to fix this in sound settings or in the Audio MIDI Setup. In that app as well, I see that there are "2 inputs" for the built in microphone, one of which I assume is my system sounds? But there is no way to test this or change any settings, most of them are grayed out and cannot be changed.

    I didn't change any settings, this computer is nearly brand new and came with the problem. Please, does anyone have a solution or any advice.
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    Your thread title says "external microphone"
    But, your OP has "built-in microphone"
    Which is it?

    Are you saying that any audio from the speakers, causes feedback from the built-in mics (?)
    If you are not using the internal mics, but just the mic on a headset, you could simply seal up the two mics on the left side with a bit of tape, and problem solved.
     
  3. kieran1111 thread starter macrumors newbie

    Joined:
    Mar 29, 2017
    #3
    I meant the internal microphone.

    I'm using headphones, there is no audio being played out of the speakers and feedback is impossible.

    I don't want to use a separate mic, I would like to fix this problem to utilize the built in mic.
     
  4. SteveJUAE macrumors 68000

    SteveJUAE

    Joined:
    Aug 14, 2015
    Location:
    Land of Smiles
    #4
    Am I reading this correct your playing video etc whilst on a skype call and the mic is getting too much feedback ?

    I think your asking a lot of Skype auto mic to sort out and probably when you went through the mic and camera setup in skype you had different background noise, voice level or even distance to the inbuilt mic

    Run through the skype set up again and adjust your voice level etc also refrain from playing video/music during a call and watch for lag as Skype thinks there are long silent pauses and ups the mic volume/sensativity
     
  5. kieran1111 thread starter macrumors newbie

    Joined:
    Mar 29, 2017
    #5
    No, this has absolutely nothing to do with skype. If I go to audio settings, I can see video sounds etc. being detected by the microphone when I have headphones on. The microphone is playing computer sounds through the computer itself, not by picking them up via the speakers.

    I tested google hangouts as well, and the same thing occurs.
     
  6. SteveJUAE macrumors 68000

    SteveJUAE

    Joined:
    Aug 14, 2015
    Location:
    Land of Smiles
    #6
    Ok thanks for clarification :)

    So have you tried different headphones or even an I phone headset ?
     
  7. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #7
    Seems like you can try a quick couple of tests when you notice that feedback. (You can choose to call it something else, but I would call it "feedback, as that is what you are describing)
    Did you try covering up the microphones (there are two, both on the left side on a MBAir)? A small bit of tape would be enough. Isolate up only one microphone at a time, test, then try blocking the other mic.
    Does the feedback instantly stop when you unplug your headphones?

    Have you always used the same headphones?
    Would it be accurate to call those headphones "noise-cancelling"? If so, test headphones that do not have that "feature"
     

Share This Page