system speed is slowing down after installing apps

Discussion in 'PowerPC Macs' started by zoran, Feb 24, 2012.

  1. zoran macrumors 68030

    Joined:
    Jun 30, 2005
    #1
    What is the reason that my system speed is slowing down when i install more applications? For example, when i make a fresh installation of the OS (Leopard on a G5) Safari is very fast not only in browsing but in opening etc. Then i begin to install Adobe CS2 or the major system software update, about 110 fonts. After all this system speed is degraded... why? What can i do to make it go back to its speed before all these installations?
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Do you have enough free HDD capacity and RAM?
     
  3. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #3
    Well on my G5 there is an 80gb HD (55free) and 3GBRam
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    And what is the RAM usage like?

    I never owned a G5 (PowerMac or iMac), thus I can't speak for them, but even my G4 iBook didn't slow down when I had another application installed (Avid Xpress, Adobe products, Combustion), it did however slow down, when I used them due to low RAM availability, as I only had 1.25 GB of RAM in that machine. Maybe your RAM gets used up and the system has to swap, but that should only occur when running applications, not when just having them installed.
     
  5. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #5
    might it be software updates? ive noticed this too on a corei7 imac, before updates it was unimaginably fast!!!
     
  6. tom vilsack macrumors 68000

    tom vilsack

    Joined:
    Nov 20, 2010
    Location:
    ladner cdn
  7. zoran thread starter macrumors 68030

    Joined:
    Jun 30, 2005
    #7
  8. tom vilsack macrumors 68000

    tom vilsack

    Joined:
    Nov 20, 2010
    Location:
    ladner cdn
    #8

Share This Page