System Wide Font Smoothing / Anti-Aliasing Disable?

Discussion in 'macOS' started by jeff_siler, Nov 9, 2007.

  1. jeff_siler macrumors 6502

    Joined:
    May 4, 2005
    #1
    All,

    I hate the OSX style of font smoothing. Even when set to the "light" setting it bugs me (compared to Linux and Windows). I'm currently using Tinkertool to "remove font smoothing on font > 144 point" but this only mildly fixes the problem. Menus and many websites in safari still have the smoothing effect.

    Is there a way to force a disabling of the font smoothing system wide? Is it a quartz setting?

    I'm seeing the same limitation on OSX 10.4 and OSX 10.5 leopard.

    thanks

    Jeff
     
  2. AlexisV macrumors 68000

    AlexisV

    Joined:
    Mar 12, 2007
    Location:
    Manchester, UK
    #2
    No, it's designed to look the way it does.

    Personally I like the look of it. If you could disable it, it would look like a pixelly mess ie. Windows XP.

    Do you not like the font rendering in Vista? It's pretty much the same as OS X.
     
  3. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #3
    Really? ...Man, Apple's font-smoothing looks WAY better than anything else I've seen. Way less colored (their sub-pixel rendering is much less aggressive), no hinting so type actually looks like type... Maybe you're too close to your monitor?

    Leaving the "turn anti-aliasing off" option out of OS X is, in my opinion, saving users from themselves. People have gotten used to crunchy, ugly type for WAY too long. Time to adjust to how text should actually look.
     
  4. jeff_siler thread starter macrumors 6502

    Joined:
    May 4, 2005
    #4
    Bummer :(

    I've got a 17" Macbook Pro High Res 1920x1200 and maybe that has something to do with it. I just think the fonts look really blurry compared to OFF. I had a Firefox 2 window open to the same page as Safari 3 and the text is so blurry its giving me headaches.

    What type of machines/monitors are you guys looking at, and at what resolution?

    What is your font smoothing value set to in the appearance preferences of Leopard (Automatic, Standard, Light, Medium, Strong)?

    thanks,

    Jeff
     
  5. jeff_siler thread starter macrumors 6502

    Joined:
    May 4, 2005
    #5
    I hate Vista's font rendering (and I hate vista ;) ) The first thing I do is to turn off cleartype on Vista and change the default font to something other than the cleartype driven Segoe UI (Something like Tahoma).

    OSX lets you disable smoothing for text < 12 point in the appearance preferences, but its really only for text in documents. Why not make it easy and allow a system wide setting?

    Jeff
     

Share This Page