Systems that boot on an original (slim) 128k Mac

Discussion in 'Apple Collectors' started by djpumpkin, Jan 29, 2008.

  1. djpumpkin macrumors newbie

    Joined:
    Jan 29, 2008
    #1
    Hello

    I have an un-upgraded 128k Macintosh. It's been running and booting from a system 2 / finder 1.1g disk with no problems. recently I thought it would be fun to get it to boot from the oldest version of the mac OS I could find. Bizarrely I have found that it will not boot from any system disk prior to system 2 / finder 1.1g which was released a year after my Mac was made.

    So far I have tried .97/1.0 and 1.1/1.1 without success. I created 400 disks using DiskDup+ and I know it worked as the disks work perfectly in my Mac Plus (which is obviously newer than the 128k!!).

    Any one have any ideas?

    The 128k Mac is the British version, although I don't think this would have any relevance.
     
  2. RacerX macrumors 65832

    Joined:
    Aug 2, 2004
    #2
    Actually, it really could.

    Because 400k wasn't a lot of room, much of the early system software was built into the system as ROM... If the ROM on your system is expecting to see a British version of the rest of the system and doesn't find it, that could be enough to stop everything in it's tracks.

    Plus I would imagine that finding compatible floppies would be something of an issue too. I have an older external floppy drive just for reading/writing early disks.
     
  3. aquajet macrumors 68020

    Joined:
    Feb 12, 2005
    Location:
    VA
    #3
    Are you saying that it's able to boot System 2 or later?

    If so, boot into a version that does work and try reblessing the older system folder. Do this by opening the older system folder and then closing the window.

    Most classic versions of mac os will let you know when the system folder is blessed by displaying a small picture of a mac on the system folder icon. These earliest versions of system software don't have that feature however, so there's no way to know for certain whether or not it's blessed.

    Are you certain this machine has a 400k floppy drive? You can differentiate between 400k and 800k drives by the inject mechanism. The 400k is manual-inject and the 800k is auto-inject. In other words, if the drive sucks in the floppy disk once you push it in, then it's an 800k drive.

    These days, it's a rarity to find 400k drives which actually function. If they do, then in all likelihood it's been serviced by a knowledgeable tech. The lubricant in the eject mechanism essentially turns into glue and must be thoroughly cleaned and re-lubricated. Not a difficult operation, but something that should certainly be done on all 400k drives if it's never been done.
     
  4. djpumpkin thread starter macrumors newbie

    Joined:
    Jan 29, 2008
    #4
    Thanks for your replies :)

    RacerX: The system 2 and 3 I tried were also US versions and booted fine, so I don't think this is the problem. I also have an apple utility app called 'Localization' which changes the keyboard layout and language resources of a system (although not the system menu language).

    aquajet: Yes, it's definitely a 400K drive - and it has been properly serviced. I did consider that it could be a disk drive issue, but since there are no other problems with other disks (reading / writing / booting) I now don't believe this to be the case. I think your point about the system folder blessing might be the problem, although it does find a system on start up (happy mac) but the next second it's lights out and a sad mac with code F0064.

    I'm lucky as I have a few good original single sided 400k floppies as well as 800k disks which I've formatted as 400k, so I will have another go at making another system 1 disk over the next day or so.
     

Share This Page