T-Mobile MMS settings?

Discussion in 'Jailbreaks and iOS Hacks' started by GFLPraxis, Aug 31, 2009.

  1. GFLPraxis macrumors 604

    GFLPraxis

    Joined:
    Mar 17, 2004
    #1
    I'm using the T-Mobile Total Internet Plan, so my Cellular Data Network APN is set to internet2.voicestream.com, NOT wap.

    What should my MMS settings be set to? The various ones I've found on Google haven't functioned so far. And sometimes the MMS APN field goes blank when I exit the menu even though I entered settings. :/
     
  2. Vegastouch macrumors 603

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #2
    MMSC 216.155.174.84/servlets/mms

    MMS Proxy 216.155.165.50:8080

    Username and password leave blank

    My APN is wap.voicestream.com so hopefully this works. It is the same settings i used when i had Swirly MMS as well and my APN on that was epc.tmobile.com so it should work i would think.
     
  3. iShater macrumors 604

    iShater

    Joined:
    Aug 13, 2002
    Location:
    Chicagoland
    #3
    Are those the only fields to fill out?

    That is what I have and it never worked for me.
     
  4. Vegastouch macrumors 603

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #4
    Thats all i have filled out and it has always worked for me but it has to be filled in the MMS section of your data.

    I have a 2G and i also have to have ActivateMMS2G from Cydia installed. Dont know what you need for a 3G

    If you have a 2G and dont have it you can get that by typing it in the sources cydia.alpden.com
     
  5. GFLPraxis thread starter macrumors 604

    GFLPraxis

    Joined:
    Mar 17, 2004
    #5
    I entered wap.voicestream.com in the APN field for MMS (data has to remain internet2, wap only works if you use the blackberry plan).

    These settings didn't work for me. Also, when I leave the menu, the APN field is reset to blank.

    Screenshots are attached, the first one is when I first enter the fields, and the second is after I hit Network to go back and reenter the settings page. See how the APN field is empty again?

    Maybe I can't use these settings if I can't use wap.voicestream.com for internet?

    And for the record; it's a 2G iPhone using ActivateMMS2G.
     

    Attached Files:

  6. GFLPraxis thread starter macrumors 604

    GFLPraxis

    Joined:
    Mar 17, 2004
    #6
    Interestingly, it seems if I put internet2.voicestream.com in the MMS APN field, the setting will stick, while wap will not. But, it still doesn't work.
     
  7. Vegastouch macrumors 603

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #7
    Well this is what im using and it has been working fine and i dont have Blackberry data plan. Hec i have the $5.99 data plan

    [​IMG] [​IMG]
     
  8. erasat macrumors member

    Joined:
    Aug 21, 2009
    #8
    I have tried it, and if you don't enter same APN in both options (DATA and MMS) it won't stick, MMS gets deleted as soon as you exit the menu. In fact, I don't use MMS right now, so I don't need it, but I always like to have everything set, you never know when you need to use it.
     
  9. divalicious macrumors newbie

    Joined:
    Feb 21, 2009
    #9
    YES! THANK YOU! (vegastouch) I have a 2G and upgraded to 3.0 but I couldnt find (well it wasnt there) activatemms2g in cydia and people were providing me with sources that didnt work the one you provided worked

    to those of you who its not working for I had to change my cell data APN to match my MMS APN (wap.voicestream.com)


    I know some people may know this but some may not.....as soon as you enter your settings dont exit the menu .....reboot your phone :) hth
     
  10. iShater macrumors 604

    iShater

    Joined:
    Aug 13, 2002
    Location:
    Chicagoland
    #10
    That was it! That is why this thing never worked, I always exited the menu before restarting and it never worked. It just did! :eek:

    Thank you! :D
     
  11. Gix1k macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
  12. divalicious macrumors newbie

    Joined:
    Feb 21, 2009
    #12




    welcome :)
     
  13. Bootsie macrumors 6502a

    Bootsie

    Joined:
    Jan 23, 2008
    Location:
    Utah
    #13
    Ok I have just been trying this, I also have a 2g phone on the t-zones plan, and i put in all the settings (using wap.voicestream.com) and I cannot get the APN setting to stick in the MMS field, I tried not exiting the menu and just rebooting from there, but it still won't stick... any solutions? Have I done anything wrong?
     
  14. MacMane macrumors regular

    Joined:
    May 1, 2009
    Location:
    Orlando, Fl
    #14
    mms works fine for t-mobile with one of the suggestions from above, however, i found that the pictures are blurry. i searched this problem on google and found something that made my pictures crystal clear. if anyone is having blurry pictures let me know so i can search for the solution again and post it. i may have posted it previously along time ago. i am using an iphone 3g on t-mobile os 3.0.
     
  15. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #15
    Yep. You just have to get a custom IPCC that spoofs the user agent to another phone, and then the pictures will be gorgeous. :D
     
  16. Vegastouch macrumors 603

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #16
    Ok, lets see the fix for this.
     
  17. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #17
    This is what you requested.

    :D

    (click the smile)
     
  18. stevelude macrumors newbie

    Joined:
    Sep 6, 2009
    #18
    MMs I phone first gen.

    How do i get the MMs option to display in the CDN tab?
    i have first gen i phone unlocked and jailbroken with cydia, t mobile is my service.

    thanks.
     

Share This Page