T-mobile users, are you getting occassional service drops?

Discussion in 'Jailbreaks and iOS Hacks' started by 1QWIK7, Feb 7, 2009.

  1. 1QWIK7 macrumors newbie

    Joined:
    Jan 10, 2009
    #1
    Like title said, im having problems with my new iphone.

    I bought my phone brand new that someone unlocked and jailbroke. Everything works fine when it needs to be but sometimes the phone doesnt.

    For instance, there would be at times (probably once a week) where i have no data, i cant check weather, cant check mail, cant go on the internet but my phone capabilities work.

    I would have to turn off, then turn on the phone to get that to work.

    HOWEVER, that itself lies another problem.

    EVERYTIME i reboot the phone, the phone doesnt recognize my sim card. It doesnt say, "no sim card" or "invalid sim". It just shows the bars icon but it doesnt say my service provider which is T-mobile. Almost like you're using the wrong sim or a sim thats not activated yet.

    In order for the PHONE to work again, i would have to pop my sim tray, wait about 10 seconds, then pop it back in again. Then it would restore itself in about 20-30 seconds.

    I have to leave my phone on all the time so i dont have to do the sim tray deal. But i have to anyway when my data gets stuck and doesnt work.

    At first i thought it was my sim card because i had it for about 5 years, plus i was looking at the gold plate contacts and it was scratched up. So i bought a new sim card a couple of days ago and had it activated last night. It worked fine right away.

    Then this morning data was shot again so i had to reboot even though i didnt want to. I was hoping everything was normal since i have a new sim card but nope, same thing, i had to pop the sim tray for 20 seconds, then reinstall and then it works now.

    My service provider is T-mobile. My phone is unlocked and jailbroken 2.2 with 2.28 firmware. The guy i bought the phone from said no turbo sim is needed so right now i use just my tmobile sim card.

    Could it be that the phone is defective?? Or are you tmobile guys having the same problem?

    Someone please help, if its a service provider thing, im gonna switch to another phone carrier.

    Thanks for reading.
     
  2. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #2
    I occasionally have brief data outages -- once every few months, though, not once a week, they last an hour or two, and the phone continues working without any intervention later. I've never had to do anything special to get the phone to recognize T-Mobile during boot. This is from 1.1.4 to 2.2.1, with every version except 2.0.0 (I used ZiPhone to unlock 1.1.4 and then I pwn'd 2.0.1, and I've just used the mainstream, non-jailbreaked firmware ever since then).

    Couple of obvious questions, but I didn't see them addressed...
    - You're talking about T-Mobile USA, right?
    - Is this an iPhone 3G or an iPhone with EDGE?
    - Is the current firmware the only one you've ever had problems with, or did you update and continue to have problems?
    - Have you ever tried redoing the unlock and jailbreak yourself on a fresh firmware copy?
     
  3. 1QWIK7 thread starter macrumors newbie

    Joined:
    Jan 10, 2009
    #3
    Thanks for the quick reply.

    Im leaning towards the phone as being the problem because i was searching for similar problems other people are having and its not as distinct as mine.

    But then other people are saying it could be the phone coverage in my area. But then why would i have that problem whenever i reboot? What does popping the sim tray have to do with clearing the problem? This is weird.


    EDIT: Yes tmobile USA. The phone is an 8GB 3G. I havent touched the phone for updates or did anything to it to modify what i originally had when i bought it.

    I am a total newb to this which is why i bought the phone already unlocked and jailbroken.

    I will try to do the fresh firmware but i dont want to mess up the phone.

    This problem has been intermittent for the past month now. I figured this is not normal and i wanna ask the experts here.

    Thanks
     
  4. 1QWIK7 thread starter macrumors newbie

    Joined:
    Jan 10, 2009
    #4
    Ok quick update. I was fooling around with the phone. Rebooting many times wondering how come it only works when i pop the sim tray for a few seconds, then reinstall.

    Then i turned on airplane mode for like a blink of an eye and turned it off.

    Icon showed "searching", then went to tmobile signal in less than 10 seconds.

    Rebooted about 3 more times, did the same thing and it worked the same.

    So now im thinking it has something to do with airplane mode? Maybe...
     
  5. coorspate macrumors regular

    coorspate

    Joined:
    May 20, 2006
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5G77 Safari/525.20)

    My phone does the same thing. Airplane mode on and off fixed just about every time.
     
  6. dorqiekat macrumors 6502a

    Joined:
    Jul 3, 2004
    #6
    I just got my phone yesterday, and once or twice, I lost my cellular network but it returned a second or two later. This morning, I am having a bigger issue. It says that I am no longer in the cellular network (like before) and now it can't find any service. On the left corner it says, "no service" and when I try to connect to my tmobile carrier in settings it can't connect. I even tried rebooting a few times and turning the airplane mode on and off. When I stick the sim card back into my blackberry, it finds service quickly and with no issues. :mad: anyone?

    Please help, I don't want to have to go back to my BB.

    I'm using the first gen iphone and unlocked and jailbreaked using the latest firmware with pwnage.
     
  7. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #7
    Next thing to try is probably restoring your firmware. The other immediately fixable possibility might be that your SIM card was not seated properly, although I'd guess you addressed that when you took the SIM out and put it back in....
     
  8. GeekGirl* macrumors 65816

    GeekGirl*

    Joined:
    Feb 26, 2009
    Location:
    Buffalo, NY
    #8
    I have the original iPhone and have no service problems at all, works perfect on T mobile.
     
  9. dorqiekat macrumors 6502a

    Joined:
    Jul 3, 2004
    #9
    funny story... I called T-mobile and it turns out that the service for the Los Angeles area was down for the hour. :rolleyes:
     
  10. moloukhya macrumors member

    Joined:
    Apr 6, 2007
    #10
    It sounds like you might be running on an old version of yellowsn0w.

    There should be an icon for "Cydia" on one of your homescreens. You need to tap it and allow it to check for updates to see if one is found for a program called yellowsn0w. THe iPhone 3g is unlocked using that program, and the early versions required you to remove and re-insert the SIM before it registered onto T-Mobile. In later versions that was corrected for most people.

    Hope that helps! :)
     

Share This Page