T-Mobile wifi calling???

Discussion in 'iPhone Tips, Help and Troubleshooting' started by surlygent, Sep 26, 2014.

  1. surlygent macrumors newbie

    Joined:
    Sep 26, 2014
    #1
    When I am in the US on t-mobile with wifi calling on the carrier name changes to "tmobile wifi" I can make/receive calls no problems, all good.

    Now I am out of the country (where wifi calling is super useful) and of course since I am oversees the carrier name is whatever carrier I am currently roaming with, even with wifi calling turned on.

    So how do I know if my calls are using wifi or using regular cell network and therefore being charged? I looked at my bill and indeed I have been getting charges for calls at times I was sure I was on a strong wifi signal with wifi calling enabled.

    I called tmobile and they were very nice and helpful but basically said its such a new feature for Apple that I need to call them as its probably a bug of some sort with OS8… apparently now they can do automatic hand off between wifi and cell calls as to prevent you from dropping wifi calls if you go out of wifi or loose signal… makes sense except there is currently no way (that we could tell) to see if your actually making a wifi vs cell call!

    Strange thing was that a day or so ago the "tmobile wifi" did appear replacing my current roaming carrier name, but only for a moment.

    So basically we have a cool new, useful feature, but pretty certain its not really working the way it is intended to - at least when your out of the country trying to make wifi calls.
     
  2. RomostyleTX macrumors newbie

    Joined:
    Sep 16, 2014
    #2
    Turn on airplane mode and then turn wifi back on. This will force the phone to use wifi calling only.
     
  3. surlygent thread starter macrumors newbie

    Joined:
    Sep 26, 2014
    #3
    Unfortunately that does not work. The phone forces you to turn off airplane mode before you can make a call. Supposedly you should be able to receive wificalls as well, but that does not work either...
     
  4. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #4
    I'm sure you have done this but triple check that WiFi calls are enabled in the Phone settings. I would reboot and then possibly reset network settings. If that doesn't work, you should reach out to TMO directly. Make sure they know of the problem so you don't get charged with anything!

    Also, make sure the WIFi connection is strong. I actually find, even at home, that when I'm further on the edges of my WiFi range (weaker signal), WiFi calling turns off and just uses the cellular connection. The WiFi you're on may also just not allow voice. It's not a problem w/ the feature or served but the WiFi network itself won't allow those type of connections.
     
  5. RomostyleTX macrumors newbie

    Joined:
    Sep 16, 2014
    #5
    Working for me. Make sure you turn on wifi calling first and then turn on airplane mode and re-enable wifi. Just tested and I'm able to make calls in airplane mode.
     

    Attached Files:

  6. tys macrumors 6502

    Joined:
    Jan 3, 2008
    #6
    I can't get wifi calling to work at all.
    The only setting I see is on/off. But I never get the "tmobile wifi" indicator.
    Is there another setting I'm missing?
    iPhone 6plus, iOS 8.0, tmobile unlimited LTE plan.
     
  7. surlygent thread starter macrumors newbie

    Joined:
    Sep 26, 2014
    #7
    Nope. Doesn't work for me. Clearly there is something not working with the wifi calling. Seems to be that for you to actually be making a wifi call the carrier name must be showing 'tmobile wifi', so all the time that I am out of the country, even though I am on strong wifi, with wifi calling enabled, that 'tmobile wifi' never shows up, just whatever carrier I am roaming on… too bad, its a potentially great feature for traveling...
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    Maybe the wifi you're connected to has certain ports blocked needed for wifi calling.
    I heard of someone's work wifi not allowing for wifi calling also.
     
  9. surlygent thread starter macrumors newbie

    Joined:
    Sep 26, 2014
    #9
    I am sure its possible, but seems odd that every wifi network I have been on in the past 6 days while overseas would have the needed ports blocked. Skype, FaceTime Audio work just fine by the way… but thats not a solution of course…
     
  10. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    Not sure.
    How many wifis did you try?
    There was another thread with someone else having similar issues. I'm going to try looking for it.
    Also try a few restarts and reset network to see if that does it.
     
  11. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #11
    Just wondering if the OP ever got this to work or figured out what the problem was.
     

Share This Page