Tab & Caps Lock keys not working after installing Sierra on 2012 rMBP

Discussion in 'macOS Sierra (10.12)' started by jk73, Dec 8, 2016.

  1. jk73 macrumors 6502

    Joined:
    Jul 19, 2012
    #1
    Title basically says it all — Immediately after installing Sierra on my 2012 15" rMBP, the Tab and Caps Lock keys stopped working.

    I haven't moved the rMBP and it hasn't been hit or damaged in any way, so unless it's the coincidence of the century, it seems like Sierra is the culprit.

    If I activate Caps Lock via the Keyboard Viewer, the green light comes on the actual Caps Lock key, so it seems like the key is getting power, etc.

    Has anyone else seen this? Any ideas on a fix? Thanks.
     
  2. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #2
    Do they work in other accounts on the machine? Try reinstalling Sierra. If that doesn't fix it, you've experienced a coincidental hardware failure.
     
  3. jk73 thread starter macrumors 6502

    Joined:
    Jul 19, 2012
    #3
    This problem is very strange. As I said in the first post, after installing Sierra, my Caps Lock and Tab keys stopped working. (I mostly only use the Tab key in Safari, so I thought maybe it was a Safari bug, but both the macOS and Safari have been updated one or more times since.)

    A few days ago, after a weird hard system crash -- I got the spinning beach ball with many tabs open in Safari, followed by an almost immediate and very fast system relaunch (i.e., no start-up chime; just a return to the log-in page, with all windows restored when I logged in). Right after that happened, my Caps Lock and Tab keys worked again for a while, but now they're not working again.

    Has anyone ever seen anything like this? I suppose this could just be a couple of weird coincidences, but I'm getting ready to sell the machine and would like to get this solved.

    Is it possible dust or something has gotten under those two keys? I'd understand if the two keys were totally dead, but it's odd for them to have resurrected themselves a few days ago. (And I know the Caps Lock key is getting power, as the green light appears if I trigger Caps Lock via the Keyboard Viewer.)

    Thanks for all feedback.
    --- Post Merged, Dec 31, 2016 ---
    No, they don't work when I log into my separate admin account, but, as mentioned above, they both worked again for a day or two recently, only to stop working again. Thanks.
     

Share This Page