Target Display mode not functioning with AV360 any more

Discussion in 'iMac' started by Ocon, Oct 23, 2010.

  1. Ocon macrumors newbie

    Joined:
    Jul 15, 2010
    #1
    Hi,

    I use a Belkin AV360 so I can play my Xbox 360 on my new 27" iMac using target display mode. it has been working flawlessly since I got the AV360 until today where I haven't been able to get target display mode to work. I've checked it is not the Xbox 360 being the problem tested it on my housemates TV. am also pretty sure it's not the Belkin AV360 itself because in system profiler under USB devices it says the "AV360 miniDP Converter" is pluged in and say same in Windows 7 bootcamp under device manager. I also tried my laptop which has a HDMI out on it. my laptop says there is a "Belkin dongle" plugged in, I set the laptop to use the Belkin dongle at a external display and still I can't get target display mode to work. Normally when I turn my Xbox on it automatically goes into target display mode or I can press cmd + F2 so to switch between iMac and Xbox. I have also tested my housemates Xbox in my setup and still the same problem.

    The only things I can think of that could have caused this are either the wacom bamboo tablet drivers I installed which gave me some ramdom error( now uninstalled ) and i booted into bootcamp earlier today as well.

    Things l've tried to fix it are:
    Rebooting Mac OS X
    Booting into bootcamp then back into Mac OS X
    Restoring from yesterday's Time machine ( target display mode was working yesterday )

    any ideas on how to fix this? or is there and way to repair snow leopard or could my mini display port be broken?

    Hope someone can help me
    -Alex
     
  2. BintangTimur macrumors newbie

    Joined:
    Nov 27, 2010
    Location:
    INDONESIA
    #2


    same problem i'm having bro, the target display mode button just won't work at all.
     
  3. PianoBoyce macrumors newbie

    Joined:
    Feb 1, 2011
    #3
    Same problem

    Was just using the product, and now it no Longer flips over to the secondary display. Was wondering if you guys have had any luck so far? I've tried clearing the PRAM and all but nothing seems to work.
     
  4. n1ght1ngale macrumors newbie

    Joined:
    Feb 2, 2011
    #4
    Same problem here. Worked fine and then nothing. Belkin UK advises they no longer manufacture the product (only came out in Nov 2010), and have no replacements. Apple are refunding me. Something strange going on here. Has an Apple update blocked the use of this device?
     
  5. jakkeri macrumors newbie

    Joined:
    Mar 28, 2013
    #5
    Same problem here...

    Did you manage to get the target display mode work? I've exactly the same problem.
     

Share This Page