Targus Numeric Keypad: Faulty or Just Incompatible?

Makosuke

macrumors 603
Original poster
Aug 15, 2001
6,152
341
The Cool Part of CA, USA
I just bought a Targus USB numeric keypad (the corded one without built-in calculator, but with a 2-port USB hub) for my MBP. Plugged it in, OSX (10.4) recognized it as a keyboard but couldn't figure out the type since it was a keypad not full keyboard, but it works... almost.

The thing is, if I turn off its own numlock, then it works fine--the arrow and page up/down keys work as expected. And when I try to type numbers I do get numbers... but it is apparently registering several "clear" keystrokes along with the number I pressed.

End result it's useless in Calculator (or the widget) since it hits clear after every number so you can't input anything, and while I can input numbers into a text document the extraneous "clear"s slow it down and make annoying beeping (since there's no defined action for that key in, say, TextEdit).

I tried it in all three keyboard styles available (ANSI, ISO, and JIC), but the behavior is identical.

Anybody have an idea if this is just a bum keypad or if it's actually not Mac compatible for some reason?

If anybody is wondering why I picked this particular one, it was because I had a $10 off coupon for Staples and I can't use the "embedded" one very efficiently; the two cheap ones they had was this Targus and a bright blue mini GE dealybob with retractable cord that was uglier than the Targus and would be harder to use on account of smaller keys. Targus didn't mention Mac compatibility and the GE did, but I figured "Hey, it's a numeric keypad--surely they're all the same".

Was I wrong?

Targus's website help is pretty much useless.
 

Makosuke

macrumors 603
Original poster
Aug 15, 2001
6,152
341
The Cool Part of CA, USA
Well, crud. Tried feeding the keypad to Windows in Parallels, and it worked just fine there without any drivers. Meaning that Windows' built-in HID driver knows what to do with it and OSX's doesn't. Hope Staples will take it back.

This totally confuses me, though--why would it register a whole bunch of "clear" button presses along with each number and the minus key (only), while all the secondary keys as well as plus, slash, and asterix work normally? This some arcane side effect of Windows-compatible keyboards that I've never heard of?
 

Makosuke

macrumors 603
Original poster
Aug 15, 2001
6,152
341
The Cool Part of CA, USA
Just a follow up for future reference:

Took the Targus back to staples and exchanged it for a bargain-basement GE (yes, the lightbulb guys) mini keypad. It's sort of sparkly blue, has smallish keys, looks cheap, and while the retractible USB cord is a nice feature it's REALLY thin so I'm wary of how long it'll hold together.

But, it works just fine, no drivers necessary. What's Targus' problem?
 

tweakers_suck

macrumors regular
Feb 7, 2005
221
0
Los Angeles, CA
Just a follow up for future reference:

Took the Targus back to staples and exchanged it for a bargain-basement GE (yes, the lightbulb guys) mini keypad. It's sort of sparkly blue, has smallish keys, looks cheap, and while the retractible USB cord is a nice feature it's REALLY thin so I'm wary of how long it'll hold together.

But, it works just fine, no drivers necessary. What's Targus' problem?
I bought the Targus keypad and still use it today. It works fine on my PowerBook G4.

When I first plugged the keypad in I got the same window as you -- select keyboard type. I simply closed out the window with the red circle and have never had a problem with the keypad.

It works for me...
 

Makosuke

macrumors 603
Original poster
Aug 15, 2001
6,152
341
The Cool Part of CA, USA
I bought the Targus keypad and still use it today. It works fine on my PowerBook G4.
Huh... aint' that weird.

You are talking about this particular model, right?:

http://www.targus.com/us/product_details.asp?sku=PAUK10U

USB, two port built-in hub, no calculator features, not one of the other ones. I'd have thought the thing was broken except it worked absolutely fine in Windows. And I did try it on my G5 tower, too--exact same thing.
 

tweakers_suck

macrumors regular
Feb 7, 2005
221
0
Los Angeles, CA
Huh... aint' that weird.

You are talking about this particular model, right?:

http://www.targus.com/us/product_details.asp?sku=PAUK10U

USB, two port built-in hub, no calculator features, not one of the other ones. I'd have thought the thing was broken except it worked absolutely fine in Windows. And I did try it on my G5 tower, too--exact same thing.
Sorry. Actually the model I have does not have the hub. I don't see how that would make a difference, though.

I think part of your problem was trying to select a keyboard type. I just closed the window because I knew the num pad wouldn't fit any of the catagories.
 

Makosuke

macrumors 603
Original poster
Aug 15, 2001
6,152
341
The Cool Part of CA, USA
I'd be inclined to agree with you except for the fact that it worked fine in Windows, and the GE keypad--which comes up with the exact same window--works perfectly (regardless of which keyboard type I choose, or none at all like you did). I'd guess that when you close the select window it just picks the default.

I note, also, that the GE one shows up in system profiler as "USB Compliant Keypad". The Targus one with the hub showed up as some sort of keyboard with an oddball chipset name and an internal USB hub.

This isn't to say that maybe if I'd just hit the close button it wouldn't have worked fine, but I'm guessing otherwise. That of course doesn't mean that other Targus keypads might not work perfectly--they more than likely use different chipsets than the one with the built-in hub.
 

Shawn Levasseur

macrumors newbie
May 12, 2009
1
1
Solution Found!!!

I just bought the current version of this model of Targus keypad (PAUK10U), and had the same problems. Landed here from a Google search on the topic.

I found a solution on in the reviews of this keyboard at Amazon.com posted by someone with the username, "The Wizard":

http://www.amazon.com/Targus-PAUK10U-Ultra-Mini-Keypad/product-reviews/B00008NG7N/ref=cm_cr_dp_synop?ie=UTF8&showViewpoints=0&sortBy=bySubmissionDateDescending#R30E5W6AUBQKQK

This doesn't work with a mac unless...

Do exactly as I say and it will work fine:

1. When your Targus keypad is disconnected press and hold the Num Lock button.

2. Connect your Targus Keypad USB cable to your mac USB port (not a hub) while still pressing and holding the Num Lock key.

3. When the Num Lock green LED light goes on, wait for exactly at least three seconds (count 1, 2, 3) then release the Num Lock Key.

4. Now it shouldn't Beep and it will work fine in programs like Excel.
 
  • Like
Reactions: robcab20

brshort

macrumors newbie
Oct 28, 2009
1
0
Austin
Works!

Thanks for that great catch Shawn. Mine works now too! So nice since it's a decent, low profile little keypad. I really wanted to make it work. Thanks!
 

ghettochris

macrumors 6502a
Feb 19, 2008
774
0
you have to keep the 000 key pushed down to use it on a mac... I love it. tips like this are why I love google. Led me right here and now my numpad works.
 

monkee4

macrumors newbie
Jan 16, 2010
1
0
Thanks Shawn

Finally I can use the keypad again! Thank you for posting this simple solution.
 

pedm

macrumors newbie
Jan 18, 2010
1
0
keypad won´t work on parallels

Hi i have a Targus USB Numeric Keypad (AKP10US) and when I plug it to the mac it works perfectly, but when I plug it to the parallels virtual machine (windows xp) it just works the +*/ signs and the arrows. i tried to put the num lock toggle but it does not work either. I have a mac book air
I will appreciate the help!!!
 

SCSI Cat

macrumors newbie
Jan 6, 2010
3
0
Read Bob Snider for an even better solution;

…I found that just holding down the NumLock key as you said for a few seconds will toggle the keypad in and out of the state where it works or not. In other words, I didn't need to unplug it to make it work. Conversely, when it is working, if I hold down the NumLock key too long, it will go back into the non-working state. So, if it is ever not working, just hold the NumLock key and count to 3.
My summery: Holding down NumLock for 3 seconds with the unit plugged in toggles Mac compatible mode.
 

Cybernose

macrumors newbie
Sep 2, 2014
1
0
Enhanced Fix

The 3 second toggle, while leaving the 10-key plugged-in, works great.
 
Last edited:

jennhein

macrumors newbie
Oct 8, 2015
1
0
Solution Found!!!

I just bought the current version of this model of Targus keypad (PAUK10U), and had the same problems. Landed here from a Google search on the topic.

I found a solution on in the reviews of this keyboard at Amazon.com posted by someone with the username, "The Wizard":

http://www.amazon.com/Targus-PAUK10U-Ultra-Mini-Keypad/product-reviews/B00008NG7N/ref=cm_cr_dp_synop?ie=UTF8&showViewpoints=0&sortBy=bySubmissionDateDescending#R30E5W6AUBQKQK
WOW! This worked great for my Targus number pad to work on my Mac. Many thanks
 

QuintinV86

macrumors newbie
Sep 5, 2016
1
0
I just bought a Targus USB numeric keypad (the corded one without built-in calculator, but with a 2-port USB hub) for my MBP. Plugged it in, OSX (10.4) recognized it as a keyboard but couldn't figure out the type since it was a keypad not full keyboard, but it works... almost.

The thing is, if I turn off its own numlock, then it works fine--the arrow and page up/down keys work as expected. And when I try to type numbers I do get numbers... but it is apparently registering several "clear" keystrokes along with the number I pressed.

End result it's useless in Calculator (or the widget) since it hits clear after every number so you can't input anything, and while I can input numbers into a text document the extraneous "clear"s slow it down and make annoying beeping (since there's no defined action for that key in, say, TextEdit).

I tried it in all three keyboard styles available (ANSI, ISO, and JIC), but the behavior is identical.

Anybody have an idea if this is just a bum keypad or if it's actually not Mac compatible for some reason?

If anybody is wondering why I picked this particular one, it was because I had a $10 off coupon for Staples and I can't use the "embedded" one very efficiently; the two cheap ones they had was this Targus and a bright blue mini GE dealybob with retractable cord that was uglier than the Targus and would be harder to use on account of smaller keys. Targus didn't mention Mac compatibility and the GE did, but I figured "Hey, it's a numeric keypad--surely they're all the same".

Was I wrong?

Targus's website help is pretty much useless.
May i ask where is the Num Lock?
 

Makosuke

macrumors 603
Original poster
Aug 15, 2001
6,152
341
The Cool Part of CA, USA
May i ask where is the Num Lock?
Wow, blast from the past.

If you're talking about the same Targus keypad (which is apparently still available almost 10 years later), it's the top left key on the keypad, and should be labeled "num lock". There are a lot of other options on the market these days, though, many (most?) of which boast Mac compatibility. A lot of them (particularly aluminum Apple-styled ones designed for the Mac) don't even have that key, nor would they need it.
 

robcab20

macrumors newbie
Feb 26, 2017
1
0
Solution Found!!!

I just bought the current version of this model of Targus keypad (PAUK10U), and had the same problems. Landed here from a Google search on the topic.

I found a solution on in the reviews of this keyboard at Amazon.com posted by someone with the username, "The Wizard":

http://www.amazon.com/Targus-PAUK10U-Ultra-Mini-Keypad/product-reviews/B00008NG7N/ref=cm_cr_dp_synop?ie=UTF8&showViewpoints=0&sortBy=bySubmissionDateDescending#R30E5W6AUBQKQK
Thanks a lot! this saved my ass in 2017!!
 

A. Bortolotto

macrumors newbie
Apr 26, 2017
1
0
"Solution": Here's a solution from a post by S. Simpson as per the below link, with my suggested adjustments for the GE retractable number pad and some additional info:

S. Simpson's solution/post:

Disabling the 000 key worked with my GE Retractable Number Pad (USB) Model 98575 connected via USB to my MacBook Pro mid-2014 running OS X El Capitan version 10.11.6 in Excel 2011.

Change to fix: But I did it slightly differently as I did not want to permanently disable the pad. So I popped off the 000 key (while not connect to the laptop), and used a tiny piece of scrap leather trimmed to fit perfectly into the back of the 000 key itself. I replaced the key and it is enough to keep the key "pressed down".

Advantages: No permanent damage as a fix, easy removal, and "soft" enough not to damage the key itself.

Disadvantage: other than the obvious, the first time you use the key pad, it "thinks" the 000 key is working and will input the 000 into the starting cell in excel.
Work around: make certain you are in a blank cell when you plug the key pad in. :)

Additional: stuck a piece of painter's tape on the 000 key with a big X to remind me it is disabled.

Good luck!

In case the link to S. Simpson's solution doesn't work, here it is in its full glory:
https://www.amazon.com/review/R30E5W6AUBQKQK/ref=cm_cr_rev_detup_redir?_encoding=UTF8&asin=B00008NG7N&cdForum=Fx12BMD49LWTZP9&cdPage=1&cdThread=Tx1AD948F6VJZP6&newContentID=Mx1P4W6X2WFFS5O&newContentNum=31&store=pc#Mx22LYVX94LS4T6