TCP Block and Airdrop between 2 MBP

Discussion in 'Mac Apps and Mac App Store' started by SD-B, Aug 11, 2013.

  1. SD-B macrumors 6502


    Apr 1, 2009
    Although I really love Lil Snitch, the fact that I can get TCP Block for free has made me want to try it.
    I am not convinced yet that I will stick with it as Lil Snitch is easier.

    In any event wondering if anyone here can help me with this one problem I have using it?

    I have 2 Macbook Pros
    1 is running 10.84 and the other I havet yet moved up to that but at present is on 10.75

    10.84 is using TCP Block and mac firewall is enabled
    10.75 is using Lil Snitch and mac firewall is enabled

    I tend to use AIRDROP a lot between the 2 but since installing TCP Block, I can no longer do it and I am not sure how to open it up again so I may!

    When trying to send a file from the 10.75 using Lil Snitch to the 10.84 using TCPBlock, I can send a file and the other Mac will receive it

    When tring it the other way, from 10.84 using TCPBlock to 10.75 it won't let it through and says, "The Transfer Failed. Try Again"

    ANY ideas what I need to type into TCPBlock so that I will be able to transfer files through Air Drop both ways?

  2. tag macrumors 6502a


    Apr 29, 2005
    Ok, I personally use Little Snitch and not TCPBlock, but I have taken a look at TCPBlock before so let me see if I can help a bit...

    Would this work... Open up TCPBlock, and turn to the 'Connecting Apps' section, then try to send out a file via AirDrop from the computer with TCPBlock running, when you get the error, check the Connecting Apps section and find out what the name of the AirDrop process is and its ports, highlight it, click the Insert to Application button, then go into the 'Application List' and whitelist the AirDrop process. (This is assuming you are using the list as a whitelist, if you aren't you need to delete the offending blocked rule I'd assume).

    If that doesn't work, and like I said I don't know if it will because I don't use TCPBlock, you could manually check the saved entries. They are stored at '/etc/tcpblock.conf' and you could search through the entries to see if anything apple related is being blocked.
  3. SD-B thread starter macrumors 6502


    Apr 1, 2009
    It worked BUT........LOL.......I did try that exact same trick back a few weeks ago when I first set it up but it didn't work at the time.

    Ive been too busy to ask about this until tonight so your post made me think it wouldn't hurt to try it again but this time I saw just 2 blocked TCP thingies and allowed them in and now i have sent 2 files back easily, just like before.

    All I can surmise is that I must have tried it when I didn't have as many things ok'd and therefore had more to OK but I guess I didn't ok the right ones, or enough but whatever the case thank you for even though i was aware of that trick I doubtfully ever would have thought to attempt it again.

    So, thanks again for your help!!!

Share This Page