TCP blocked but ipfw list is empty

Discussion in 'Mac OS X Server, Xserve, and Networking' started by dgrant, Nov 28, 2011.

  1. dgrant macrumors newbie

    Joined:
    Nov 28, 2011
    #1
    Hello,

    I am trying to set up BIND/named to host my own DNS. I appear to have a blocked port but ipfw is pleading innocent. I have set up a port forward ('virtual server') on my router; public port 53 to private port 53, TCP and UDP. I'm have turned the firewall off completely in the prefs panel.

    Code:
    /etc$ sudo ipfw list 
    65535 allow ip from any to any 
    
    /etc$ nc -vz x.x.x.x 53    (my external IP) 
    ^C    (hangs) 
    
    /etc$ nc -vz 127.0.0.1 53 
    Connection to 127.0.0.1 53 port [tcp/domain] succeeded! 
    
    Can anyone suggest what the next step to look at might be?

    Thank you,
    Darren
     
  2. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #2
    Is named actually listening on the external address?

    netstat -an | grep LISTEN

    A.
     
  3. Mattie Num Nums macrumors 68030

    Mattie Num Nums

    Joined:
    Mar 5, 2009
    Location:
    USA
  4. dgrant thread starter macrumors newbie

    Joined:
    Nov 28, 2011
    #4
    I got it sorted, thank you for the suggestions!

    I have a modem, and a wifi router behind it. I was forwarding the port from the router to my Mac, but not from the modem to my router.

    Cheers :)
     
  5. Mattie Num Nums macrumors 68030

    Mattie Num Nums

    Joined:
    Mar 5, 2009
    Location:
    USA
    #5
    That makes sense!!!
     

Share This Page