tcsh to bash permanent change in terminal?

Discussion in 'Mac Basics and Help' started by JBsea, Apr 11, 2013.

  1. JBsea macrumors newbie

    Joined:
    Jan 25, 2012
    #1
    I change usr/bin from login to bash in Terminal's preferences but for some reason the changes don't always stay. I can't tell what triggers it, but the shell changes back to tcsh. Is there a command I can type to permanently set the terminal to bash? Thanks.
     
  2. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #2
    Which version of OS X are you using? From memory, bash became the default way back in 10.3 (although if you upgraded from 10.2 then it kept tcsh). Is it correct to assume that you have something newer? Did you manually change to tsch in the first place?

    Anyway, here are the official instructions, using Terminal Preferences.
     
  3. JBsea thread starter macrumors newbie

    Joined:
    Jan 25, 2012
    #3
    10.6.8

    Thanks for the reply but I already changed terminal in preferences like the link you sent explains but it reverts back to tcsh for no obvious reason (sometimes it happens the same day, sometime it happens in a week).
     
  4. dakwar macrumors 6502

    Joined:
    Nov 2, 2010
    #4
    In terminal, first type
    Code:
    which bash
    This should return "/bin/bash" without the quotation marks.

    Then in terminal type
    Code:
    chsh -s /bin/bash
    Enter user password if necessary.

    Log out of your user account, then back in. I usually like to do a complete system shutdown and restart after such changes.
     
  5. JBsea thread starter macrumors newbie

    Joined:
    Jan 25, 2012
    #5
    thanks

    done, thanks... I'm guessing it should work fine now but I'll give an update if anything changes.
     

Share This Page