Teamviewer asks for my admin password and remote login question

Discussion in 'Mac Apps and Mac App Store' started by aoitsukinosuke, Oct 24, 2012.

  1. aoitsukinosuke, Oct 24, 2012
    Last edited: Oct 24, 2012

    aoitsukinosuke macrumors regular

    Jun 13, 2011
    I'm new to Teamviewer.
    It's installed on my Mini, with a permanent password, set to open at login.
    When I restart my Mini, it starts as instructed.
    However, when I quit manually and try to restart, it asks for my admin password.
    Is this normal or should I be wary of something?

    Also, there are some peculiarities that started ever since I set my permanent password.
    1) My HP printer is making those preparatory noises like when you try to print something. This happens about twice a day when the Mini is idle.

    2) Today I noticed that my desktop background was blank, which is usually the case when I remotely control my Mini.

    I immediately checked TVW, no connections. Then, I quit TVW and it was back to normal.

    Does this mean someone was remotely connected?

    Can someone give me a hand?
    PS= My session pass is set at "Very secure 10 characters" and I never shared my permanent pass with anybody.
  2. GGJstudios macrumors Westmere


    May 16, 2008
    How exactly did you install TeamViewer? Are you launching it from your /Applications folder or from the .dmg you downloaded?

    Are you sure it's asking for your Mac's admin password, or another password you set in TeamViewer?

    You should re-check all your TeamViewer preferences. If that doesn't help, try uninstalling/reinstalling TeamViewer.
  3. aoitsukinosuke, Oct 24, 2012
    Last edited: Oct 24, 2012

    aoitsukinosuke thread starter macrumors regular

    Jun 13, 2011
    I downloaded it from their website though when I clicked download, it took me to and installed.
    The app is in a folder named "Teamviewer 7" in my Applications folder.

    It's definitely asking for the admin password.
  4. aoitsukinosuke thread starter macrumors regular

    Jun 13, 2011

    I followed your advice and did an uninstall. Then went to their website which took me to for download.
    I redownloaded and when I tried to install, my OS asked for my admin pass, which is normal, but after that TVW asked for my admin pass again.
    I cancelled install, called TVW hotline and they asked me to send my logfiles, but I don't have any since I uninstalled previously.

    Then, I tried reinstall again, this time TVW didn't ask for the admin pass and worked like a charm.

    Now, when I go to preferences and check the "Start with system" box, it asks for my admin pass once more.

    What could the reason be for this?
  5. GGJstudios macrumors Westmere


    May 16, 2008
    What version of Mac OS X are you running?
    Are you logged in as an admin user?
    In TeamViewer > Preferences > Advanced > TeamViewer Settings (near the bottom) > Protect preferences with password (do you have a password set? Do you have "Changes require administrative privileges on this computer" checked?
  6. aoitsukinosuke thread starter macrumors regular

    Jun 13, 2011
    Leopard 10.5.8
    Logged in as admin user
    No password set
    Box is not checked.

    (I'm 100% positive about the admin pass, because the UI states my Mac OS user name, not the TVW one)

    BTW; While Teamviewer > Preferences > Start TVW with System option at TVW preferences requires the admin pass, "Open at login" at the app shortcut on the dock doesn't.

    Another thing is, this may sound funny, as long as TVW is on, the printer turns itself on even though I shut it down manually.

    I'm trying to give my observations to narrow down the field. Hope I'm not making it more complicated for you.

    Thank you for your time & concern.
  7. aoitsukinosuke thread starter macrumors regular

    Jun 13, 2011
    A reinstall solved the printer problem.

    That is also confirmed. IMHO; this is something Teamviewer needs to correct. Until then I'll stick to "Open at login"
  8. cmdawson macrumors newbie

    Jul 12, 2011
    Any update? having same issue here

    I'm also having this issue and have tried all the above steps to resolve with no luck. (Even repairing permissions has not helped...)
  9. JoelBC macrumors 6502a

    Jun 16, 2012
    I have the same experience...every time I start it up it asks for my admin password no matter what I do...
  10. cmdawson macrumors newbie

    Jul 12, 2011
    Same here

    Any updates from anyone on this? I have been annoyed by this for a while now too...

    FYI - I did do a "Repair permissions" on my disk but this did not help, so still looking like an issue for them to correct.
  11. grafkaal macrumors newbie

    Jul 5, 2010
    Still no change!

    TV starts with no "enter password" prompt when I start up my Mac (Start TeamViewer with system - checked) but as soon as I try and start it when the machine is on up pops the "Type your password to allow TeamViewer to make changes." box again! I have tried everything I can think of but nothing seem to work.
    My major problem with it is - if I forgot to start TV before I go to work I have no way of tuning it on remotely because of the "enter password" box!
    I can use ssh and run the terminal command "open -a teamviewer" but then cannot enter password to complete the process (unless someone out knows how I can), I even tried to make an Automation app that entered the password and clicked OK, but no, Automation would not enter the password! I can use the ssh terminal command "sudo reboot" but that is such a pain!
    Any help would be very much appreciated! Applescript to fill the securityAgent fields perhaps?
  12. zzz99 macrumors regular

    May 31, 2010
    I have resolved this problem by installing the Teamviewer 6 full version on the MBA 2013.

Share This Page