technical: font problem questions (OSX)

Discussion in 'Mac Help/Tips' started by jvaska, Oct 11, 2002.

  1. jvaska macrumors 6502

    Feb 18, 2002
    some of us osx users can not use our fonts...i have ALOT of postscript fonts...and i NEED them for my work...but EVERYTHING comes up as bitmapped when i load them into suitcase...

    except one font...

    i downloaded a font off of the internet...and it worked...???

    so...after reading around...i found a person who thinks the problem is with i checked four of my fonts that i have loaded...and sure enough...three of them...the three that won't work...have different permissions than the one that did work...


    -rwxrwxrwx 1 jvaska admin 0 Jun 20 2000 Nyx
    -rwxrwxrwx 1 jvaska admin 0 Jun 20 2000 Nyx.
    -rwxrwxrwx 1 jvaska staff 0 Aug 23 1999 Silkscreen

    silkscreen works...nyx does i changed the permissions on nyx to staff using still doesn't work...

    so...i am wondering if it makes any sense to any of you ultra talented techie people here...should i keep playing with this? or is this route really a clear dead end?


    ps: oh yeah...i'm on osx 10.1.5 (i'm not going to 10.2 as i hear many people there are having the same problem - i'm not spending a dime on new os software until there is a clear fix)...g4/400...lots and lots of ram...i also have 9.2.2 on a different drive...
  2. Doctor Q Administrator

    Doctor Q

    Staff Member

    Sep 19, 2002
    Los Angeles
    Permissions rwxrwxrwx mean "owner can read/write/execute, group owner can read/write/execute, and everyone else can read/write/execute". In other words, everyone has full access to the file, as long as they have access to the directory (folder) that it lives in. So whether the file's group owner is "admin" or "staff" wouldn't appear to matter. However, you could change the group of Nyx to "staff" just to see if it makes a difference.

    If your files have full permissions and permissions were really the cause of your font problem, it would more likely mean that a directory (folder) has the wrong owner, group owner, or permissions, not that the files with rwxrwxrwx are the problem. But since Nyx and Silkscreen are in the same directory, any folder permission problems would apply to them equally.

    Which leads me to conclude that you don't have a permissions problem.
  3. jvaska thread starter macrumors 6502

    Feb 18, 2002
    thanks...makes sense...

    this drives me crazy...ONLY truetype fonts script fonts do not...SO...i'm dealing with it from this perspective (a second time around)...nothing i have tried works...and i've tried everything...

    but lots of other people have this problem...

  4. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    I havent' gotten all of my fonts to show up yet but I haven't bought Suitcase yet either.

    I was thinking about loading Suitcase into both Mac OS 9.x and 10.x. I thought that if it found all of my fonts in 9.x, it should be able to create the relationships for me in a similar fashion to ATM. Then, when I went into Mac OS 10.x, it might have those relationships for use there too.

    Have you tried that?
  5. jvaska thread starter macrumors 6502

    Feb 18, 2002
    yes...i've had this suspicion myself...and i think you should try that...

    i haven't tried this yet myself...but i'm planning to do so when i have more time...

    i did find a note elsewhere...a guy said that he solved his problem by using only ONE set of fonts for both...part of the problem (apparently) has to do with osx not displaying fonts because they are found elsewhere (os9)...

    but there is more to the problem really though...osx is under performing right now with fonts for alot of who knows what will work and what won't work at the moment...

    if you us know what happened...i'm certainly curious to know...


Share This Page