Temperature monitoring in the new 2017 iMac?

Discussion in 'iMac' started by StudioSanctum, Jun 9, 2017.

  1. StudioSanctum macrumors member

    StudioSanctum

    Joined:
    Mar 7, 2017
    Location:
    Planet Earth
    #1
    Does anyone have any idea why I can no longer see the temperatures of the sensors in the new 2017 iMac? Neither the iStat app or the MONIT app show system temperatures. Any help would be appreciated.
     
  2. Moriarty macrumors 6502

    Joined:
    Feb 3, 2008
    #2
    The software probably needs updating for the new Kaby Lake processors. Try the Intel Power Gadget or HWMonitor (the latter says it's been updated for Kaby Lake).

    Which processor do you have? I'm curious what the CPU temperatures and fan speeds are under heavy load (e.g. Prime95)...
     
  3. StudioSanctum thread starter macrumors member

    StudioSanctum

    Joined:
    Mar 7, 2017
    Location:
    Planet Earth
    #3
    Thanks! HWMonitor does seem to be showing temps. However, any idea what's up with HDD Bay 1 and 2? The temps are reading 120 degrees Celsius while everything else is sitting around 35. I know this isn't right!
     
  4. Moriarty macrumors 6502

    Joined:
    Feb 3, 2008
    #4
    Don't worry, that will be a software glitch. No way those temps are real.

    If any temperature sensors are broken or actually reading very high values, the fan will be going like crazy.
     
  5. evilgawd macrumors newbie

    evilgawd

    Joined:
    Jun 23, 2010
    #5
    fyi , the dev fixed the issue for istats and now reports correctly, you will need to quit istats and re-download https://bjango.com/mac/istatmenus/ then re-install the package for it to work .
     

Share This Page