Temporarily disable ALL notifications

Discussion in 'Jailbreaks and iOS Hacks' started by mdwittenberg, Apr 1, 2013.

  1. mdwittenberg macrumors newbie

    Joined:
    Jan 28, 2011
    #1
    How can a user temporarily disable all notification behavior in iOS 6? "Do Not Disturb" allows banners -- I don't want banners.

    Ideally, I'd love a simple toggle just as iOS 4 had under settings.


    Why? I'd like to stream videos without being distracted by banners. This has been an issue since iOS 5. Now, I've jailbroken and am eager for an answer.

    Thanks,
    Mitch
     
  2. c0venant macrumors regular

    Joined:
    Jun 26, 2012
    #2
    I'd love that option back too. Sometimes friends use my iPad and I don't want them seeing certain notifications. An option to disable all at once rather than doing one by one would be great.
     
  3. cyks macrumors 68020

    cyks

    Joined:
    Jul 24, 2002
    Location:
    Westchester County, NY
    #3
    When the screen is on, like when watching videos, everything is allowed through, not just banners. 'Do Not Disturb' only works when the screen is off.

    It amazes me how Apple shows parents using their iPads to teach their children, employees using them for presentations, and friends playing games together (sharing a device) when they don't allow us to turn off all notifications.

    Sadly, too often the chance for something inappropriate to pop on screen outweighs all else and I end up using my iDevices less because of it.

    It woukd be nice to have a toggle that killed all notifications...and would love to have user accounts (something that's been heavily requested since the introduction of the iPad).
     
  4. mdwittenberg thread starter macrumors newbie

    Joined:
    Jan 28, 2011
    #4
    Thanks c0venant and cyks for responding.

    Too bad there isn't a solution.
     
  5. Heavy Fluid macrumors 6502

    Joined:
    Jun 18, 2008
    #5
    I simply turn the banners/popups off. I didn't want things popping up when I would show people pictures or videos or whatever on my phone. There is no need for them to see my email or text messages. I feel like the banners and popups are far too intrusive into the phone, and having them off is refreshing.
     
  6. Ol!ver macrumors 6502a

    Joined:
    Mar 2, 2005
    #6
    Airplane mode is the current solution. Not ideal, but it's workable.
     
  7. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #7
    Have you tried BannerDisable? That's what I used to use on iOS 5 to block banners

    Edit: It used to block UIAlertViews too but looks like the newest version removed that for some reason. If I were you and that's something I wanted to use, I would either contact the dev and asked for the older version which had that feature or I'd look for an old deb file. Another option would be to use the current version found in Cydia plus use something like PopupBlocker to block the UIAlertViews.
     
  8. mdwittenberg, Apr 2, 2013
    Last edited: Apr 2, 2013

    mdwittenberg thread starter macrumors newbie

    Joined:
    Jan 28, 2011
    #8
    @Heavy Fluid: I'm hoping to hang onto the ability to use banner notifications for all but watching movies and loaning my iPad. Personally, I do find value in banner alerts 80% of the time, though that 20% may drive me to disable them completely without the ability to toggle on/off.

    @Ol!ver: Great idea for offline tasks, though I stream most of my media

    @BumpyFlatline: Woo hoo! BannerDisable seems to do the trick for me; thank you so much. I'm not sure what more disabling "UIAlertViews" would do - are those the two button pop-ups that require a selection (aka "Alerts" according to Notification Center settings)?
     
  9. BarryL macrumors 6502

    Joined:
    Dec 2, 2012
    #9
    I need to try that too. Hate to being talking to a hot chick and I get a sms from another chick.
     
  10. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #10
    Awesome! Yea exactly. Those are popups. Glad this worked for you!
     

Share This Page