TenFourFox locks up CONSTANTLY

Discussion in 'PowerPC Macs' started by MatthewLTL, Jul 14, 2015.

  1. MatthewLTL macrumors 68000

    MatthewLTL

    Joined:
    Jan 22, 2015
    Location:
    Rochester, MN
    #1
    I thought it was due to running the "e" on 512MB RAM but even with 1.5GB it still locks up constantly I have followed all the guides on here to "Speed" ur TFF but those guides never made the preformance of the computer, while running TFF, any better at all.
     
  2. bunnspecial macrumors 603

    bunnspecial

    Joined:
    May 3, 2014
    Location:
    Kentucky
    #2
    Is TFF crashing or is your whole system?

    If it's the latter, bad RAM would be my first guess. Try an AHT disk.
     
  3. MatthewLTL thread starter macrumors 68000

    MatthewLTL

    Joined:
    Jan 22, 2015
    Location:
    Rochester, MN
    #3
    It's TFF, It doesn't crash it beachballs and will either stop after about 30 seconds but most of the time it never recovers. i have to :apple:+Option+Escape and force quit it.
     
  4. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #4
    Are you using the stable or the beta version?

    If the beta, stick with the stable. If the stable version, try the beta.
     
  5. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #5
    What sites are you using? My PowerBook will only beach ball if I either have a CPU intensive task running (like Mail) or if the site is full of garbage like JavaScript and other resource pigs. Even when it beach balls, it is only for an extremely brief amount of time (a few seconds).
     
  6. MatthewLTL thread starter macrumors 68000

    MatthewLTL

    Joined:
    Jan 22, 2015
    Location:
    Rochester, MN
    #6
    I am using the Stable version 31.8.0
    It usually happens here on MacRumors or while using Google Voice website. (VoiceMac no longer seems to function properly)
     
  7. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #7
    For MR, try turning off the rich text editor and the Flash uploader. It's in your MacRumors account preferences.

    As to Google Voice, I can't help there as I don't use it.
     
  8. Dronecatcher macrumors 68000

    Dronecatcher

    Joined:
    Jun 17, 2014
    Location:
    Lincolnshire, UK
    #8
    Regardless of browser, you'll get the occasional rainbow wheel due to script content - day by day sites are getting harder to accommodate under PPC - and don't forget, that is only a 1Ghz machine. I take it you've tried a script/advert blocker?
     
  9. MatthewLTL thread starter macrumors 68000

    MatthewLTL

    Joined:
    Jan 22, 2015
    Location:
    Rochester, MN
    #9
    I have NoScript, Google Disconnect, Adblock, Flashblock all installed.
    Thanks! Doing that right now!

    EDIT already have the Flash Uploader turned off.
     
  10. A.Goldberg macrumors 68000

    A.Goldberg

    Joined:
    Jan 31, 2015
    Location:
    Boston
    #10
    You use Google Voice on an emac? I'm surprised that even works.

    These might also be overwhelming your computer.
     
  11. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #11
    More likely NoScript is not set correctly. If you "Allow" specific sites then it allows ALL the sites that it connects to (including analytics and ad sites) unless a site is on the "Untrusted" list.

    You have to go back and deny permission to each of the sites the specific site connects to in order to allow connections to that site but deny connections from the sites you do not want.
     
  12. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #12
    I don't think you need Flashblock on TenFourFox.
     
  13. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #13
    Correct. You can set NoScript to block any Flash as well, although as you imply plugins for T4Fx are disabled - which would include Flash.
     
  14. 556fmjoe macrumors 65816

    Joined:
    Apr 19, 2014
    #14
    I would dump Adblock and Flashblock. Adblock uses enormous amounts of RAM. Bluhell is much faster if you want a browser based adblocker. Flashblock is not necessary if Flash is disabled.
     
  15. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #15
    ABP (I assume you mean ABP) has a memory leak and it's pretty huge. They still have not fixed it. That's where your enormous amounts of RAM is coming from.

    If you must use an AB product, use AdBlock Edge (ABE). Much better, more efficient, but still inferior to BluHell Firewall.

    Also, just a note…Ghostery also has a huge memory leak (still). I used to use it, but I found better ways to block analytics and ad sites.
     
  16. 556fmjoe macrumors 65816

    Joined:
    Apr 19, 2014
    #16
    Correct, I meant ABP. I have not found a browser based solution better than Bluhell.
     
  17. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #17
    Neither have I. It's ONLY flaw is that it does not block ads on Facebook for some reason. But other than that it's extremely light and blocks everything ad related.
     
  18. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #18
    I used to use AdBlock Pro but was overcome with vast amounts of CPU and RAM usage with little return. Any speed difference was overshadowed by a lot of beach balling and poor general performance. Under eyoungren's recommendation, I switched to Bluhell Firewall and I must say that it is the best I have ever used. There is actually a test somewhere online comparing all of the ad blockers and Bluhell came out on top. In summary, @MatthewLTL switch to Bluhell and probably half of your problems will go away.
     
  19. MatthewLTL thread starter macrumors 68000

    MatthewLTL

    Joined:
    Jan 22, 2015
    Location:
    Rochester, MN
    #19
    Thanks everyone. I have installed BluHell, however, it seems that turning off the MR RichText stopped the beachball. I will run for a few days with BluHell and get back to all of you.
     
  20. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #20
    The rich text editor really is a dog on slower machines. Disabling it works great!
     
  21. lowendlinux Contributor

    lowendlinux

    Joined:
    Sep 24, 2014
    Location:
    North Country (way upstate NY)
  22. val1984 macrumors member

    Joined:
    Jan 26, 2015
    #22
    Using uBlock wouldn't be a bad choice too :)
     
  23. MatthewLTL thread starter macrumors 68000

    MatthewLTL

    Joined:
    Jan 22, 2015
    Location:
    Rochester, MN
    #23
    I think this was a eMac/RAM issue. The issue don't exist at all on the MDD and the issue went away on the eMac after upping the RAM
     

Share This Page