Terminal command in Sierra does not work with Circus Ponies Notebook v.4

Discussion in 'macOS Sierra (10.12)' started by CLOD-HOPPER, Jan 20, 2017.

  1. CLOD-HOPPER, Jan 20, 2017
    Last edited: Jan 20, 2017

    CLOD-HOPPER macrumors member

    Joined:
    Oct 10, 2015
    #1
    Hello — Recently, I started to use Sierra 10.12.2, having cured the teething problems with Photoshop that had occurred weeks ago. I thought that everything was now fine, until I tried to apply a Terminal command to Circus Ponies v. 4. The command was given to me many months ago, by the now defunct C.P. Notebook team, and is meant to enable C.P.N. to create new "writing pages" (at some point, these became unobtainable. (After a certain point in the C.P.N. updates, only "note-pages" were available, and these are no good to me.)

    Anyway, the instructions given by the C.P.N. team were as follows:

    Follow these steps to enable Writing pages in NoteBook (quit the NoteBook application prior to doing these steps):

    1. Open the Terminal application. This a command line application and is found in the Utilities subfolder of your Applications folder.

    2. At the prompt, type (or copy and paste):


    defaults write com.circusponies.NoteBook.Mac “Allow Writing Pages” YES


    3. Press Return. You’ll see a new prompt, and that means the command was executed.

    You’ll now find the ability to add a Writing page from the Page menu. END OF INSTRUCTIONS

    This worked fine when I ran El Capitan, but, for some reason, the command does not work when running Sierra.


    Is there anyone out there that can usefully comment on this? If someone can help, I should be very grateful!

    With thanks in hope,

    C-H

    PS: Here, I paste in the results, in the Terminal window, of trying to apply the command above:

    2017-01-20 15:29:56.570 defaults[1221:35458] Unexpected argument Pages”; leaving defaults unchanged.


    [Process completed]
     
  2. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #2
    Did you receive an error in Terminal after entering this? It's possible that the quotes are the problem, if they're "curly quotes." (What you typed has the curly quotes around Allow Writing Pages and won't work in terminal as-is.)
    Code:
    defaults write com.circusponies.NoteBook.Mac "Allow Writing Pages" YES
    Otherwise, the command is valid and works in 10.12.2. Whether or not it still has any effect on the application you're trying to use is a different matter.
     
  3. CLOD-HOPPER thread starter macrumors member

    Joined:
    Oct 10, 2015
    #3
    Chrfr, you are a genius! I copied your command, applied it to Terminal, and it worked. Now, a new menu option has appeared, which is New Writing Page. Believe me, I am so grateful for this.
    With best regards,
    Clod-Hopper
     
  4. cdavey macrumors newbie

    Joined:
    Apr 19, 2017
    #4
    Hey, it's great to hear that Circus Ponies is still working in Sierra! It doesn't claim to work beyond 10.11, El Capitain.
    Can you confirm that it's still working fine? Have you tried it with 10.12.3 or 4?
     
  5. CLOD-HOPPER thread starter macrumors member

    Joined:
    Oct 10, 2015
    #5
    Yes, it works fine in 10.12.4
     
  6. cdavey macrumors newbie

    Joined:
    Apr 19, 2017
    #6
    Awesome, thanks!
     
  7. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #7
    Sadly, CPN doesn't work in High Sierra (beta). Hopefully it will work by the time it's out of beta, but am looking at alternatives now. I'll probably export all my old notebooks (which are now static) to HTML. I currently use CPN for book authoring and it looks like I can just move everything to within Scrivener. I also use it for general notes and will probably use Apple's Notes app.
     
  8. CLOD-HOPPER thread starter macrumors member

    Joined:
    Oct 10, 2015
    #8
    Thanks for the warning, talmy. I intended simply to update, when H.Sierra was released. Now, I shall be cautious, as I would not want to lose C.P. Notebook if it is at all possible.
    However, recently, as a precaution against its eventual loss, I tried out DEVONThink Pro. It's expensive, in my opinion, but it's very good, as it will store any kind of file. (Unfortunately, it's not as convenient in format as CPN.) You may like to look at it.
    C.H.
     
  9. cdavey macrumors newbie

    Joined:
    Apr 19, 2017
  10. CLOD-HOPPER thread starter macrumors member

    Joined:
    Oct 10, 2015
    #10
    C.P.N. version 4 works fine in 10.12.6
    C.Hopper
     
  11. cdavey macrumors newbie

    Joined:
    Apr 19, 2017
    #11
    Thx!
     
  12. ehooft macrumors newbie

    Joined:
    Nov 11, 2017
    #12
    Hi - Please let me know if CP Notebook works with High Sierra. I am hesitant to upgrade until I know the implications. Thanks!
     
  13. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #13
    It does not work in High Sierra. Not even in the 10.13.2 betas. So consider it gone. I'm sticking with Sierra for a while at least since High Sierra offers nothing I need, but I've moved off of CPN -- I've exported archival notebooks to PDF and HTML so I can still reference their contents. Currently active notebooks I've moved (manually) into Growly Notes which I'd put as a cross between CPN and OneNote, or into Scrivener for writing projects I'm working on. Growly Notes is a mere $5 in the App Store.

    Good luck!
     
  14. CLOD-HOPPER thread starter macrumors member

    Joined:
    Oct 10, 2015
    #14
    Unfortunately, C.P.N. does NOT work fully in High Sierra. You can use it just for text files. (I even edited one text file, while booted up in High Sierra, and it seemed to accept that OK.) However, it will not even open an image file, but just crashes when you click on the page. So, I purchased DevonThink Pro. and am transferring all my millions of files, from C.P.N., across to it. If, eventually, one is compelled to buy a new Mac, it would not run anything less than High Sierra, so I am doing the preparatory work, while there is still time.
    With kind regards,
    C.H.
     
  15. HugoMe macrumors newbie

    Joined:
    Jun 17, 2014
    #15
    Aargh. I've been resisting so far to move away from CPN, but with the iOS version becoming obsolete (can't sync anymore due to Dropbox API change; 32 bit app, so won't work with iOS 11), and now this High Sierra incompatibility, seems CPN's time is really over. I'm using it for a one-fits-for-all purpose for collecting any idea I want to remember, so I greatly appreciate the outlining abilities and integrated multi-media abilities. It will be difficult to replace.
    I tried to track developer Jaysons Adams but there is little sign he wants do do anything about it.
    I heard that Notetaker, which is based on the same NEXT original code is preparing something for end of year (https://www.aquaminds.com/blog-1/tag/NoteTaker 4), but they we're not very reliable in the recent past, so we'll see.
     
  16. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #16
    Looks promising, maybe, but certainly had looked like abandonware last time I checked back when Circus Ponies folded. No particular reason to select it unless it can import CPN notebooks! I always had a love-hate relationship with CPN -- it did everything I wanted but the UI was whacky and I suspect they changed as little code as possible from NEXT to get it to work in OS X.
     

Share This Page