Terminal Copy and Paste

Discussion in 'OS X Mavericks (10.9)' started by metier, Oct 23, 2013.

  1. metier macrumors member

    Joined:
    Feb 20, 2012
    Location:
    Texas
    #1
    Since upgrading, in terminal if I copy some text and paste it into a
    Rich Text Document it copies the background along with the text. I do a lot of terminal sessions to routers and firewalls, and prefer to use terminal with black background and green text. Ever since the upgrade if I copy the text and paste it into a rich text document it copies the black background and the green text just as you see in terminal, I can get around this by converting the document to plain text, but that is a pain.

    Before the upgrade copy and paste would only copy the text portion not the background. Anybody know a setting to change so when you copy text from terminal it will only copy the text?

    Thanks in advance
    Pat
     
  2. DaPhatty, Oct 23, 2013
    Last edited: Oct 23, 2013

    DaPhatty macrumors member

    Joined:
    Jul 12, 2008
    #2
    I'll have to check this for myself. I usually copy/paste from Terminal into MS Word. I'd imagine there is a setting in the Terminal Preferences that would control this feature.

    EDIT: Looks like you are right. Copy/Paste into Notes results in the text color and background being copied as well. I haven't found a setting that would control this either. FWIW, Word 2011 for Mac doesn't retain the background color, only the text color which can easily be modified using Word's built in formatting features (i.e. Keep text only).
     
  3. aaroncon macrumors newbie

    Joined:
    Oct 23, 2013
    #3
    Use Edit --> Paste and Match Style.

    Or the crazy keyboard shortcut for that...
     
  4. metier thread starter macrumors member

    Joined:
    Feb 20, 2012
    Location:
    Texas
    #4

    Tried that and it still paste the background and the green text. Anyway thanks for the suggestion.
     
  5. MacMyDay macrumors regular

    Joined:
    Oct 3, 2003
    Location:
    Cambridge, England
    #5
    A nuisance for me too, so would love to know of any magical answers
     
  6. Nugget macrumors 65816

    Nugget

    Joined:
    Nov 24, 2002
    Location:
    Houston Texas USA
    #6
    Yeah, this drives me crazy. I can't believe someone at Apple thought it was a good idea.
     
  7. gonewestcoast macrumors member

    Joined:
    Jun 16, 2009
    #7
    I'd agree. I'm assuming there's a way to disable this, but I've not found it yet.
     
  8. metier thread starter macrumors member

    Joined:
    Feb 20, 2012
    Location:
    Texas
    #8
    I have checked everything I can think of but still can not find a way to turn it off.
     
  9. tgwaste macrumors 6502a

    tgwaste

    Joined:
    Sep 18, 2013
    #9
    Same thing happening to me. VERY VERY annoying!!

    Anyone find a fix yet?
     
  10. smithrh macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #10
    Ran into this the other day - it's nasty. Had to type in a bunch of text by hand to get around it.
     
  11. w0lf macrumors 65816

    w0lf

    Joined:
    Feb 16, 2013
    Location:
    USA
    #11
    Paste and match style works fine for me.

    You could also just have like a plain text document that you paste into and then copy from there.
     
  12. smithrh macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #12
    Ahhh... but you see, that's exactly what I did.

    What got pasted was not just the text, but also the default font of TextEdit!

    Same for vi fer cripes sake.

    Who thought of this madness?
     
  13. aaronvan Suspended

    aaronvan

    Joined:
    Dec 21, 2011
    Location:
    República Cascadia
    #13
    I love my archaic green font and black background...when I'm in a terminal. Not in a freaking text document, though!
     
  14. hyperboloid macrumors newbie

    Joined:
    Nov 5, 2013
    #14
  15. tgwaste macrumors 6502a

    tgwaste

    Joined:
    Sep 18, 2013
    #15
  16. matamoris macrumors regular

    Joined:
    Sep 3, 2011
    #16
    This was one of several eccentricities of Terminal that forced me to move to iTerm2. I'm much happier with my terminal experience now.
     

Share This Page