Terminal crashing. Unable to change root pass.

Discussion in 'Jailbreaks and iOS Hacks' started by bellevegasj, Oct 26, 2010.

  1. bellevegasj macrumors newbie

    Joined:
    Jun 12, 2008
    #1
    I just installed Cydia and Terminal on my iphone4. It seems to jailbreak fine, so the first thing I did was to install the terminal so I could change the passwords. When I tap the terminal icon, it opens for a second then closes. I modified/reinstalled it a couple times. Rebooted the device. I messed with it for a bit, then restored the device and tried it again with no luck.

    I found a thread that suggest using - Google Mobile Terminal 426.

    Is that the best solution?

    Thanks,
    J.
     
  2. doubletap macrumors regular

    Joined:
    Jan 2, 2009
    #2
    best solution is to buy issh and connect to localhost.

    dt
     
  3. Bijiont macrumors newbie

    Joined:
    Sep 16, 2010
    #3
    I use terminal I got from PodZombie. . . works fine and it's free. Quick google search and you can find the repo and website.
     
  4. joec1101 macrumors 6502

    Joined:
    Jun 29, 2010
    Location:
    So Cal, USA
    #4
    I had the same problem. I don't think the Terminal program on Cydia has been updated for use with ios 4.1. The easiest/best way to do this is to install OpenSSH on your iPhone through the Cydia store and then use OSX Terminal on your computer to SSH into the phone (you can use Putty if you're running Winblows). Once you SSH in from your computer, you can perform the same functions (i.e. changing root password, etc.)
     
  5. dccorona macrumors 68020

    dccorona

    Joined:
    Jun 12, 2008
    #5
    if you want a working terminal, add this repo

    http://cydia.xsellize.com/

    and install mobile terminal-iOS 4 beta, this is the version of terminal which works with iOS 4
    but be wary, many of the other apps on that repo are cracked cydia store apps, so look to see if theres another version of an app before downloading it from there, often you'll run into apps you are supposed to be paying for (if someone knows of another, safer source that the terminal beta is on, let me know, ill edit this post to point to that source instead)

    as for changing your password, you can get the working terminal, or install rockapp (search for rock, its in the modmyi repo)

    it won't do anything now that its been bought by cydia, but when you first launch it, itll ask you if you'd like it to change your SSH password for you, just tell it what you want the password to be and you're all done. After that, you can delete rock
     
  6. bern43 macrumors member

    Joined:
    Sep 28, 2010
    #6
    The terminal on the podzombie repo seems to work fine. Just add the repo and you should be all set.
     
  7. ZCherub macrumors 6502a

    ZCherub

    Joined:
    Jul 7, 2010
    Location:
    GA, USA
    #7
    2nd this and Bern43. This worked well for me.
     
  8. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #8
    A couple of reliable sources out there. I grabbed a copy from funkeyspacemonkey and it was a clean install. Even though I have iSSH (app store) on my device, for some reason I feel comfortable having Terminal as well. Redundancy I guess!
     
  9. fsck-y dingo macrumors 65816

    fsck-y dingo

    Joined:
    Jun 14, 2009
    #9
    I installed MobileTerminal 472 manually.

    http://code.google.com/p/mobileterminal/

    The only issue I had was the icon not showing up properly. It was just a white square. So I put this icon into the app folder through SSH and all is well. :)
     

    Attached Files:

  10. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #10
    You don't need a local terminal to change the password. Once you install OpenSSH on the iPhone, just SSH to your iPhone from your computer with the root account and once in, you can use use passwd to change the password. Then do a passwd mobile to change that password too. :)
     

Share This Page