Terminal doesn't login or accept any commands

Discussion in 'macOS' started by Thunderforge, Jan 31, 2010.

  1. Thunderforge macrumors newbie

    Joined:
    Dec 12, 2009
    #1
    So today I opened up my terminal and I get absolutely nothing:

    [​IMG]

    Normally, it starts up saying my name and whatnot (I'm not too familiar with the Terminal or UNIX commands, sorry), but right now, it doesn't do anything. It will let me type something in, but hitting return does nothing. I've tried sending a soft and hard reset, logging out of my account, and even changing the "Shells open with" command in the Terminal preferences. Nothing happens.

    Could someone who is a bit more knowledgeable tell me how to fix my Terminal?
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Do you use Terminal frequently? What have you done since you used it last? Have you tried rebooting? I'm not sure what this means:

    If not, it's probably a problem with your .bash_profile file. Try following some of the steps here:

    http://forums.macosxhints.com/archive/index.php/t-48059.html
     
  3. Thunderforge thread starter macrumors newbie

    Joined:
    Dec 12, 2009
    #3
    Typically, I don't use the Terminal very often and really don't do beyond what I'm instructed to do. Most recently, I was following the official instructions found at this link to fix a Juniper Network Connect program that my school uses. I was partly through that when this behavior happened. This is the only thing I've tried to do since I upgraded to 10.6

    When I said I sent a soft and hard reset, I mean that I used the menu options in the "Shell" menu of the Terminal. I assumed that they would attempt to reboot the shell session, but they aren't doing anything.

    I'll try the steps with the ._bash profile, although I can't do the ones that require you to type stuff in.

    EDIT: Turning on "Show Hidden Files" and removing the .bash_profile did not fix the problem. I've put it back for now.
     
  4. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
  5. Thunderforge thread starter macrumors newbie

    Joined:
    Dec 12, 2009
    #5
    Unfortunately, that didn't work either. Same behavior.

    EDIT: Well, I restarted and now it's working. Thanks for all your help.
     
  6. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #6
    Restarting usually fixes a lot of things. Why didn't you do what miles01110 suggested right away?
     

Share This Page