Terminal Issues

Discussion in 'macOS' started by Rydah805, Aug 4, 2011.

  1. Rydah805, Aug 4, 2011
    Last edited: Aug 5, 2011

    Rydah805 macrumors newbie

    Joined:
    Jul 28, 2011
    #1
    Hello, I'm new to the community, and would like to say hello as I ask my first question.

    Whenever I try to open Terminal, I get this message: memory freeing cannot be allocated. set a breakpoint in malloc_error_break to debug.

    I do not know what to do. I cannot enter anything in any terminal windows. I had some issues with my root user profile (couldn't log into it) and an Apple rep had me repair disc permissions. Since then I also noticed I get errors with the Drop Box app from DropBox.com won't sync due to permission errors. (I've un installed and re installed and still doesn't work.) Now that we fixed my root user profile, I'm having these issues. What permissions should my main hard drive be set at? I'm the only profile (admin)

    Thanks in advance guys!

    -Rydah

    Oh...
    27'' iMac OSX Lion.
     
  2. Rydah805 thread starter macrumors newbie

    Joined:
    Jul 28, 2011
    #2
    Never mind me, I learned a few tricks and fixed it along with fixing some other things. I can sleep now. (My mind wouldn't stop thinking, "what can I do to fix this?")
     

Share This Page