Terminal - permissions screwed up

Discussion in 'macOS' started by blasetheodore, Jan 22, 2007.

  1. blasetheodore macrumors newbie

    Jan 20, 2007

    I have a second internal drive with screwed up permissions. This happened when I wiped OSX server off my primary drive, and replaced it with a fresh copy of 10.4. Basically I run into issues moving and deleting files and folders. I used "get info" to assign the owner and group of the drive, but the "apply to enclosed" was disabled.

    I've tried the following to get it to work:

    ls -l /Volumes
    total 8
    drwxr-xr-- 19 blase wheel 748 Jan 20 23:28 Files
    lrwxr-xr-x 1 root admin 1 Jan 22 08:25 Macintosh HD -> /

    sudo chown -R blase:wheel /Volumes/Files
    sudo chmod -R 754 /Volumes/Files/

    Both throw hundreds of "Operation not permitted" errors.

    I know there's a real simple solution to this. Anyone know how I can fix it?

  2. yellow Moderator emeritus


    Oct 21, 2003
    Portland, OR
    Err... why are you in the wheel group?

    Just do a Get Info on the drive in the Finder and select the "Ignore ownership on this volume" checkbox.

Share This Page