terminal + ssh question

Discussion in 'Mac Apps and Mac App Store' started by mayoko185, Jul 12, 2007.

  1. mayoko185 macrumors member

    Joined:
    Jun 15, 2007
    #1
    When ever I ssh into my remote (linux) server and use nano to make a quick edit to a webpage or add/remove new code iv been having an issue on my MBP. My delete key (which normally deletes left like a backspace key) starts to delete right like a normal windows keyboard delete key. This just about drove me nuts late last night trying to do a quick edit. I need my delete (backspace) key back in nano! Anyone out there who knows how to change terminals behavior?

    P.S. I doubt its an issue with the remote server as when I use windows/putty everything works as expected.
     
  2. odinsride macrumors 65816

    odinsride

    Joined:
    Apr 11, 2007
    #2
    just found this on a google search:



    There an annoying problem with Ubuntu. Using the command line editor nano, the backspace key acts sometimes as the delete key. You can fix this problem by adding the following line to your /etc/nanorc file:

    set rebinddelete



    I know it says it's for Ubuntu but it may work for OS X as well.
     
  3. mayoko185 thread starter macrumors member

    Joined:
    Jun 15, 2007
    #3
    added that line to my /etc/nanorc file and my delete key still acts as a delete key :rolleyes:

    I tried to do some googling but I couldent find any mac specific nano issues...
     
  4. mayoko185 thread starter macrumors member

    Joined:
    Jun 15, 2007
  5. odinsride macrumors 65816

    odinsride

    Joined:
    Apr 11, 2007
    #5
    what happens when you use Fn+Delete? That shortcut usually acts as a forward delete on Apple laptops...I'm curious to see what that does for you in nano.
     
  6. mayoko185 thread starter macrumors member

    Joined:
    Jun 15, 2007
    #6
    Fn+delete still deletes right as if im just pushing delete (nothing changes). What is even more weird is if I use nano with a local file on my HD everything works as expected but when I ssh into another server (iv tried a few now) it deletes like a delete button again. iv had to use putty via a windows vm as this weird delete button behavior drove me nuts to the point I wont use the mac terminal to ssh anymore...
     
  7. Vmaatta macrumors regular

    Joined:
    Nov 11, 2007
    #7
    nanorc edit helped

    I've had this same problem. I'm connecting a Debian server from Leopard through ssh and otherwise things are fine but in nano I've had that same problem with the delete key..

    Anyways..
    You can fix this problem by adding the following line to your /etc/nanorc file:

    set rebinddelete

    That worked like a charm for me :). And just to state the obvious I edited the nanorc on the Debian side :D.
     
  8. rohitbaba macrumors newbie

    Joined:
    Nov 29, 2007
    #8
    issue with My Leopard OSX connecting to iphone on SSH.

    Hi

    I have issue with My Leopard OSX connecting to iphone on SSH.

    I have tried
    FUGU
    Cyberduck
    Filezilla

    But no luck.

    However my PC does connect via Winscp so i can only assume it problem with Leopard OSX.

    please let me know of any update. Email dhaval.natu@gmail.com

    Thanks
     

Share This Page