Terrible Flash performance pretty much renders my Mac unusable.

Discussion in 'macOS' started by Nikos, Mar 7, 2013.

  1. Nikos macrumors 68000

    Nikos

    Joined:
    Nov 20, 2008
    Location:
    New York
    #1
    I'm using Mac OS X 10.8.2 and Flash Player 11.6.602.171.

    I tune in to an online video broadcast of a radio show every day for a few hours. Lately, the video has been playing in slow motion. I've also noticed this on other flash based video sites. I discovered that using Chrome helps but I don't like using it, so I open a Chrome window to watch my show while I work in Safari. Flash still hogs up my system's CPU up to ~150% regardless, rendering my computer almost unusable. The fan is also constantly running to the point that it heats up my room.

    To say this is an annoyance would be an understatement. My MacBook's specs are in my sig. This is clearly an issue between OS X and Flash. I tried to do research but couldn't find a solution other than "don't use Flash."

    Is anyone else experiencing this? Is there some sort of workaround? Any and all help would be much appreciated.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    I use Flash on Safari with ClickToFlash to control which content plays, and I have zero issues with it. Generally speaking, Flash is notorious for consuming system resources, raising temps and decreasing battery life. For Flash-related issues:
    • Find your Flash version and make sure it's the latest version available. Never install or update Flash from a pop-up on a website. Always go to Adobe's site to get Flash or updates.
    • Install ClickToFlash (Safari), Flashblock (Firefox) or FlashBlock (Chrome) to control which Flash content plays on websites.
    • Install ClickToPlugin (Safari) to prevent Safari from launching plug-ins automatically, resulting in faster browsing, reduced fan usage, and increased battery life. It can also replace many plug-in-based media players with Safari’s native HTML5 media player.
    • Try using the YouTube HTML5 Video Player to watch YouTube videos, when available. (May impact fullscreen viewing. See link for details.) Some have reported better performance with HTML5, while some have reported worse. Try it and find out what works best for you.

    If you've gotten a message that the Flash plug-in was blocked, your Flash player likely needs to be updated to the latest version.

    Adobe Flash Player updates available for OS X on February 7, 2013
    Adobe Releases Flash Player Update to Patch Security Holes as Apple Blocks Earlier Versions
     
  3. justperry macrumors G3

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #3
    Try in a new User Account, if it's gone there you have User Account related issues, but as per the Above (GGJstudios) poster Flash is notorious for high CPU usage.

    But, I do expect your Hardware acceleration to be off and that might be causing the CPU to have high usage.
    Really, try in a clean other User Account, to do so make a new User in Users & Groups, logout and into the new one and see what happens there.
     
  4. Nikos, Mar 7, 2013
    Last edited: Mar 7, 2013

    Nikos thread starter macrumors 68000

    Nikos

    Joined:
    Nov 20, 2008
    Location:
    New York
    #4
    Thanks for the suggestions. Blocking flash on other sites doesn't really have much to do with my issue. Even if one flash video is playing in a pop-out window, it's constantly using 50-70% of my CPU. Doing anything else while watching is laggy most of the time. I'm already using YouTube's HTML5 player.

    ----------

    Good idea! I'll try that and report back. :)

    EDIT: Tried a new user account and it's somehow worse. 80-100+% CPU usage with one or two Flash videos playing.
     
  5. justperry macrumors G3

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #5

    As I said before, your Hardware acceleration might be set to of in Flash preferences, I think you have to right click a Flash video to see those preferences.
     
  6. Nikos thread starter macrumors 68000

    Nikos

    Joined:
    Nov 20, 2008
    Location:
    New York
    #6
    Just checked, it's enabled. :eek:
     
  7. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #7
    With both ClickToFlash and ClickToPlugin you can select HTML5 as your default player, instead of playing content with the Flash plug-in. This works on most sites, and should greatly reduce your dependence on Flash.
     
  8. justperry macrumors G3

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #8
    To be clear, if you use Chrome it is better but how much better, is it still soso or much better and the fans run quit.

    If it's more or less the same it's system wide.
    If you haven't already done so try reinstalling Flash although I don't think it will solve the problem.

    If nothing works a reinstall will probably resolve this, but it also seems 10.8.3 is on the horizon and solves this.

    If it was me I would get to the bottom of the problem until it's solved, but you need to know the System and can take many hours if not days to solve.
    Many times the problem resides in the main Library if it is system wide but finding which folder does this is difficult.
    One folder which you could look into is the Internet plugins, move all plugins out of it except Flash, logout and in and see if the problem is gone, actually a safari or another browser relaunch should do.

    Edit: Now I think of it, a week or so I didn't see any Flash, I then disabled Extensions and it worked, you might try disabling Extensions if it's on.
     
  9. CitrusPisser macrumors member

    Joined:
    Apr 20, 2013
    #9
    Getting superior download speed and CPU/GPU temperature performance since switching to HTML5 through clicktoflash.. bye bye flash!
     
  10. Morod macrumors 68000

    Morod

    Joined:
    Jan 1, 2008
    Location:
    On The Nickel, over there....
    #10
    Thanks for these links! I just installed ClickToPlugin and ClickToFlash and viewing videos on my iMac is much better! No lagginess, no jitters, just smooth playback.
     
  11. Morod, May 12, 2013
    Last edited: May 12, 2013

    Morod macrumors 68000

    Morod

    Joined:
    Jan 1, 2008
    Location:
    On The Nickel, over there....
    #11
    Sorry for quoting myself, but...
    After installing ClickToPlugin and ClickToFlash, youtube works great. Unfortunately, all the web sites that use Flash don't. Is there any way to enable Flash as well as keep what I have already? If so, how?
    Thanks for any help!
    PS... My Flash player is the latest version.
     
  12. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #12
    You can go to ClickToPlugin or ClickToFlash preferences and add sites to the control list to allow or disallow Flash content on a site-by-site basis.
     
  13. Morod macrumors 68000

    Morod

    Joined:
    Jan 1, 2008
    Location:
    On The Nickel, over there....
    #13
    Hey, it works! Thanks for the info.
     

Share This Page