[TERRIBLE MESS] Cant delete partition, wasted 25 gb space!

Discussion in 'OS X Mavericks (10.9)' started by kayleee, Apr 19, 2015.

  1. kayleee macrumors regular

    Joined:
    Nov 20, 2013
    #1
    [​IMG]

    As you can see the partition 25gb is greyed out and the - minus sign isn't available


    I actually had this issue 2 months ago but i didn't find any solution


    now again I started searching for solutions and still no help


    Also, I has yosemite installed on it previously.

    I deleted it and I cannot delete the partition anymore....


    I tried installing yosemite on it again...and guess what?

    It stops in between giving some error, when installing on that 25gb drive.


    Please help, I'm in desperate need.

    Thank you.
     
  2. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
    #2
    The problem is you installed Yosemite on it and now are trying to modify the disk on Mavericks. Basically Yosemite updated the disk drive to support "Core Storage", there's a one liner out there that will let you revert that from the command line. Here: http://awesometoast.com/yosemite-core-storage-and-partition-woes/

    (It would be easier to just use Yosemite by the way...)
     
  3. kayleee thread starter macrumors regular

    Joined:
    Nov 20, 2013
    #3
    wow thanks for the help but for me , it says 'no' under reversible

    [​IMG]
     
  4. Zedcars, Apr 20, 2015
    Last edited: Apr 20, 2015

    Zedcars macrumors 6502

    Zedcars

    Joined:
    Apr 5, 2010
    Location:
    Brighton, UK
    #4
    I may be wrong, as I'm no expert, but a possible answer is to get an external USB hard drive a bit bigger than the Macintosh partition and use Carbon Copy Cloner (CCC) to clone the partition onto the external drive. Then format the entire Mac drive as 1 partition and copy the clone back onto the drive. CCC has a fully functional 30-day trial.

    However, take what I've said with a large pinch of salt as I don't have a lot of experience in these matters. Perhaps someone else could chime in and say whether that would work or not.

    CCC also allows you to clone the invisible Recovery HD which is important as you will need to put that back onto the formatted drive as well.

    I would also suggest backing up your important documents to another location if you attempt the above.

    Good luck.
     
  5. RV-ABZ, Apr 20, 2015
    Last edited: Apr 20, 2015

    RV-ABZ macrumors 6502

    Joined:
    Apr 11, 2013
    #5
    So, even though there is no partition and disk space appears as free, you cannot extend your existing Mavericks partition to recover that 25Go disk space?
     

Share This Page