Terrible Wi-fi and Bluetooth

Discussion in 'Mac mini' started by Springsteen, Aug 24, 2013.

  1. Springsteen macrumors member

    Springsteen

    Joined:
    Aug 5, 2013
    #1
    Hello everyone.
    When i got my Mini back in spring everything seemed peachy, but it did have two major flaws, one which i didn't find out about until just a month ago.

    From the beginning the Bluetooth was at best dodgy. Worked for a minute, lagged for a minute. Now, my Mini is mounted behind a Cinema Display (which might cause interference) but the same problem is apparent while its sitting right next to me (right or left of said screen). I am using a Magic Mouse as of writing.

    Now, for some reason i wasn't very bothered by that, but now we upgraded our broadband from 10mbt to 60mbt. The other Macs in our household: 58mbt up & down. My Mini: 10 up, 6 down.
    I tried moving it closer to the router, but no change in speed. The room right across has an iMac which gets full speed. I find this very weird.

    Im not sure what to do. Is this a known problem with the late 2012 Minis (i7, 10gb RAM) or is this truly a one-of-a-kind?
     
  2. paulrbeers macrumors 68040

    Joined:
    Dec 17, 2009
    #2
    Let me guess, you have a USB3.0 device plugged into your Mini?
     
  3. Springsteen thread starter macrumors member

    Springsteen

    Joined:
    Aug 5, 2013
    #4
    I only have a FireWire 800 drive and the Cinema Displays USB and MiniDP connected to it, thus nothing that would actually interfere (or does it even matter if it's 2.0 or 3.0?).

    But if that is the truth then i feel really bad for the engineer who put this together.
     

Share This Page