Tethering problem with 4.2.1

Discussion in 'iPhone' started by matracy68, Nov 23, 2010.

  1. matracy68 macrumors newbie

    Joined:
    Nov 23, 2010
    #1
    I downloaded the new 4.2.1 yesterday and at first didn't notice anything out of the oridinary. This morning when I went to tether my phone to my MacBook Pro, the tethering part would not work. I have gone into the settings on the phone and made sure that tethering was in fact turned on and it is. I do not see the typical 'blue' banner at the top when I am plugged in and my MacBook does not recognize my phone as a network connection anymore.

    Does anyone else have this same issue?

    How about the screen lock only allowing you to lock in portrait?

    Thanks in advacne for the help.
     
  2. Mark Booth macrumors 65816

    Mark Booth

    Joined:
    Jan 16, 2008
    #2
    Are you paying for tethering through AT&T? If you haven't added that to your account, and you were tethering "illegally" under a previous firmware update, then 4.2.1 turned off your hack or jailbreak that allowed it.

    Mark
     
  3. matracy68 thread starter macrumors newbie

    Joined:
    Nov 23, 2010
    #3
    Yes Mark, I am paying AT&T to tether. I have cycled the tether switch off and on a few times and restarted the phone with the same results.
     
  4. matracy68 thread starter macrumors newbie

    Joined:
    Nov 23, 2010
    #4
    I was able to get my phone to tether using Bluetooth but not the USB cable. Under network preferences I get an error now saying: "Either the cable for iPhone is not plugged in or the device is not responding."

    I never got this error before when I connected via USB to tether.
     
  5. ajarnfalang macrumors regular

    Joined:
    Oct 27, 2010
    #5
    Funny.

    Working flawlessly on Windows 7.

    I have an Apple Network Adapter in Device Manager. I noticed when the phone restarted it reinstalled all the USB drivers automatically.

    First time I tethered it asked me if it was a "Home Network", clicked OK.

    Done.

    I was going to say maybe remove the USB drivers and Apple Ethernet Device from the device manager and let it reinstall, but you have a MAC.

    No idea.
     
  6. matracy68 thread starter macrumors newbie

    Joined:
    Nov 23, 2010
    #6
    I did some other research and noticed some others overseas were messing with some settings inside the phone. I played around with these settings and my iPhone 4 is now tethering via USB cable to my MacBook Pro. I was able to tether using Bluetooth but not the cable.

    The other sources mentioned going into the Cellular Data settings and changing some stuff. Being in the US, there are no settings that we can change around so I played with the phone.

    Here's what I did and it worked on my phone. I went to Settings-General-Network. I toggled the Cellular Data from On to Off and then back On. iTunes did a sync and then everything worked fine. In Network Preferences on the MacBook Pro, my iPhone showed up green like it used too and the blue tether banner was on. I don't know if this was some sort of 'official' fix but it made my tether work using the USB cable.
     

Share This Page