Text edit for html, doesn't work. Help please.

Discussion in 'macOS' started by Darth Maynard, Mar 11, 2010.

  1. Darth Maynard macrumors member

    Joined:
    Jan 26, 2007
    #1
    Hello all,

    I hope I'm posting in the correct forum. The web developers forum didn't seem like the right place for my problem, but I guess we'll see.

    I recently upgraded from a G5 dual 2.0 (OS 10.4.11) to a new mac mini (OS 10.6.2). I have a website that I maintain after getting a pro to set it up for me many years ago. Basically, I would change the text and images as needed using Simpletext. Yes, doing everything in Classic. Now, I recently made some changes using Textedit, saving as an html. I uploaded using Fetch (5.5) and the page displays only the html and not a web page.:confused:

    I tried doing the same thing in MS Word with the same result.

    Any suggestions?

    Thanks for your help,
    Tim

    www.timmaynard.com
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    You're probably saving it as Rich Text instead of Plain Text. You need to save it as Plain Text.
     
  3. Koronis macrumors member

    Koronis

    Joined:
    Feb 16, 2009
    Location:
    Windsor,Ontario,Canada
    #3
    Open the textedit preferences, in the open and save tab, you need to check the box that says
    ignore rich text commands in html files
     
  4. Darth Maynard thread starter macrumors member

    Joined:
    Jan 26, 2007
    #4
    Plain text isn't listed as an option. Web page is. I tried once before to use OS X.x for my web updates using TextEdit and couldn't get it to work. I was pleased to see that I could save it as a web page (.html). I tried saving it using file format: "web page" and got this result.
     
  5. emiljan macrumors 6502

    emiljan

    Joined:
    Jan 25, 2010
    Location:
    Michigan
  6. Darth Maynard thread starter macrumors member

    Joined:
    Jan 26, 2007
  7. Koronis macrumors member

    Koronis

    Joined:
    Feb 16, 2009
    Location:
    Windsor,Ontario,Canada
    #7
    That drove me crazy for a while when I first started using text edit
     
  8. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #8
    If rich text were the default, you can change a document to plain text by choosing Format --> Make Plain Text or Command + Shift + T.
     

Share This Page