Resolved text file problem

Discussion in 'Mac Basics and Help' started by darkweather, Feb 7, 2015.

  1. darkweather, Feb 7, 2015
    Last edited: Feb 9, 2015

    darkweather macrumors regular

    darkweather

    Joined:
    Aug 8, 2013
    #1
    when i save a txt file with any file editor (like textedit or textwrangler) on os x yosemite, in windows notepad app words are non separated. for example:
    what i write in os x is:
    one
    two
    three

    in windows notepad app it is:
    onetwothree

    how can i solve this?
    (sorry for bad english)
     
  2. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #2
    In TextWrangler:
    1. Choose "Save as..."
    2. A Save dialog sheet appears.
    3. For the "Line breaks" popup, choose "Windows (CRLF)"
    TextEdit doesn't have a "line endings" option.


    What's probably happening is that you've saved the file with Unix (LF) line endings. A programmer's text editor on Windows would probably treat the LFs correctly, but I don't think NotePad knows what to do with them.
     
  3. darkweather thread starter macrumors regular

    darkweather

    Joined:
    Aug 8, 2013
    #3
    thank you.
     

Share This Page