Text Formatting Issue

Discussion in 'Mac Basics and Help' started by Jas123, Feb 12, 2011.

  1. Jas123 macrumors member

    Joined:
    Apr 1, 2008
    #1
    Sometimes when I am using Text Edit, and some other text programs as well, the formatting that I apply gets stuck. So, every new line that I create there after, gets the same formatting.

    I believe it only happens if I apply the formatting afterwards. That is, after I finish typing, I highlight the text and apply a bold or underline format.

    How do I stop this? Is there a keyboard command?
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #3
    Also, be aware that if you copy text from another source and paste it (Command-V) into a TextEdit document, it pastes the format, as well. To avoid this and retain the format you already have set in your document, use Edit > Paste and Match Style or Option-Shift-Command-V.
     
  4. mstriker macrumors newbie

    Joined:
    Jul 15, 2011
    #4
    GGJ,

    Do you think you could help to paste format?

    I recal that there is a button in Word/Excel in Windows that will allow you to copy format of a selected text than apply it to a new text.

    Is there such a thingie on Macs (whether it is mail,pages, etc.)?
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    Whether that functionality exists really depends on the particular apps you're copying from and pasting to.
     
  6. interrobang macrumors 6502

    Joined:
    May 25, 2011
    #6
    In Word 2008 and later, it's the Format painter button in the toolbar; it looks like a blue paintbrush and you click it once to copy and again to apply the style. And it only works once, so you end up clicking it a lot.

    Pages uses Format > Copy Character Style and Format > Paste Style.

    In Mail, it's Format > Styles > Copy Style and Format > Styles > Paste Style (at least in Mail 4.5)
     

Share This Page