Text from iPhone to "@" sign?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Smohrman, Oct 28, 2011.

  1. Smohrman macrumors newbie

    Joined:
    Oct 28, 2011
    #1
    Hi- this one is making me feel stupid, but i have a text address I want to text to which is formatted "text@address.com". There does not seem to be a way to add the "@" sign to an address in the text app. There's no alternative keyboard. How do you text to an address with an "@" sign in the address?
    Thanks in Advance
    Smorhman
     
  2. dotme macrumors 6502a

    Joined:
    Oct 18, 2011
    Location:
    Iowa
    #2
    That looks like an email address (Several carriers offer their customers an email-to-text option, meaning yourphonenumber@yourcarrier.com)

    Is that what the format looks like? (1234567890@example.com)? If so, drop the @example.com and just send an SMS to the number and I would think it would work fine.

    If it's not all digits before the "@", you probably have to send an email instead of a text.
     
  3. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #3
    What iPhone are you using? My keyboard on iOS 5 offers the @ sign, right down at the bottom right, so I can text an email address.

    Alternatively, add it to your contacts, then text select that contact.
     
  4. Smohrman thread starter macrumors newbie

    Joined:
    Oct 28, 2011
    #4
    The address is text@agradioshow.com. It's a Sacramento CA based radio show. They say people text them live all the time at that text address. There's not even a period on my keyboard so I can't even do the .com? WTH? There are only letters, and the alternate keyboard accessed by pressing "123" is numbers ONLY- no other characters whatsoever. I'm using a 3Gs with IOS 5. Could it be the phone is too old? I've attached a couple of screenshots of the keyboard as I can access it within the native text program.

    THX!
     

    Attached Files:

  5. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #5
    Weird! Are you on iOS 5, or not?

    That keyboard is definitely different than the newer ones.
     
  6. Smohrman thread starter macrumors newbie

    Joined:
    Oct 28, 2011
    #6
    Yup. On IOS 5
     
  7. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #7
    Here's some screenshots of the keyboard in my 4S and it's very similar on my iPad.
     

    Attached Files:

  8. Smohrman thread starter macrumors newbie

    Joined:
    Oct 28, 2011
    #9
    That's great, but that's the regular keyboard, not the one which comes up in the "Messaging" app.

    ----------

    And I just tried putting the text@agradioshow.com address into the iPhone's Notes program. I can put it in there because the regular keyboard does have the special characters. Copied it and pasted it into the Messaging app address bar. I thought I had it beat, but the iPhone converted the freakin' @ symbol to an "a". Damn it.
     
  9. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #10
    No, if you look, those screenshots were all taken in my messaging app, just to respect others privacy, I didn't select a contact. I just let the keyboard pop-up and took a screenshot.

    As I said, I'm on the 4S, though.

    That video shows the 3GS keyboard in messaging, because that's what he's typing.
     
  10. Smohrman thread starter macrumors newbie

    Joined:
    Oct 28, 2011
    #11
    My 3Gs definitely has a different keyboard in the messaging app than it does when typing in say, Notes or email. I don't know what else to say- must be the diff between 3G and 4G. There does not seem to be a way to change it anyway. Thanks for the help.

    ----------

    You have to go to "Settings/Messages/SMS/MMS and turn MMS Messaging On. That did it. After that i have the keyboard with the @ symbol. Whew, that was weird.
     
  11. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #12
    Wow! Odd, but at least you found a solution! LOL
     
  12. Arnezie macrumors 65816

    Arnezie

    Joined:
    Oct 10, 2011
  13. cathlabnurse macrumors newbie

    cathlabnurse

    Joined:
    Oct 25, 2011
    Location:
    Tennessee
    #14
    I have the @ sign in messenging when i go for a new message, however, when i go to reply, it is not there. :(
     

Share This Page