Text Messaging no longer works with Messages - Yosemite/iOS 8

Discussion in 'iOS 8' started by joejoejoe, Apr 7, 2015.

  1. joejoejoe macrumors 65816

    Joined:
    Sep 13, 2006
    #1
    Text message doesn't seem to be working well anymore in my messages app on mac.

    I've tried all the steps of disconnecting my imessage, reconnecting, disabling and reenabling handoff in settings.

    Before, a person's name in the To: field would show up green, showing that text messaging was working.

    Now they show up red and Messages doesn't want to send them.

    The odd thing is they still pop in to Message if the sender is sending me a text, but I can't respond. Messages seems to only think it can respond with an iMessage.

    Help?

    Thanks!
     
  2. theshoehorn macrumors 6502

    Joined:
    Jul 6, 2010
    #2
    I had this happen to me once, i had to go into Preferences in Messages and re-sign into iMessage.
     
  3. CTHarrryH macrumors 65816

    Joined:
    Jul 4, 2012
    #3
    seems to happen to me every once in a while and as prior said - i have to go into preferences and sign back into iMessage
     
  4. joejoejoe thread starter macrumors 65816

    Joined:
    Sep 13, 2006
    #4
    Thanks guys.

    I had to go one step forward.

    Had to go to settings > messages > text message forwarding

    and from there switch off text message forwarding and switch it back on.

    works like a charm now!
     
  5. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #5
    Ah, the old "switch it off then switch it back on again" all-purpose computer fix :)
     

Share This Page