Text not crisp after applying Mojave

drewaz

macrumors 6502
Original poster
Dec 4, 2012
336
204
Phoenix
I know others have noticed this on a non retina display but I'm really having trouble dealing with the fuzzy text on a retina iMac.

I tried turning off Dark mode and it didn't seem to make a difference.

Does anyone have a work around?
 
Last edited:

DeltaMac

macrumors G4
Jul 30, 2003
10,287
2,703
Delaware
Try running this terminal command:
Code:
defaults write -g CGFontRenderingFontSmoothingDisabled -bool NO
You should see a change in text as a result of that command. Be sure to restart before deciding if it improves your fuzzy text.
If that does not make your text sharper, you can revert that command by running it again, replacing NO with YES.
 

drewaz

macrumors 6502
Original poster
Dec 4, 2012
336
204
Phoenix
Try running this terminal command:
Code:
defaults write -g CGFontRenderingFontSmoothingDisabled -bool NO
You should see a change in text as a result of that command. Be sure to restart before deciding if it improves your fuzzy text.
If that does not make your text sharper, you can revert that command by running it again, replacing NO with YES.
thanks man but I am a total non techie and have never ventured into terminal.

I see now though that there is a check box for "use font smoothing when available" ... should this make any difference? Mine is checked by default.
 

DeltaMac

macrumors G4
Jul 30, 2003
10,287
2,703
Delaware
You can try turning that font-smoothing setting off.

But, the terminal command directly affects how text is displayed, by changing how the pixels are actually displayed in a font (anti-aliasing), and can make text characters sharper.

There's more details on this page.
 

getrealbro

macrumors 6502
Sep 25, 2015
423
162
The freeware application Tinkertool provides lots of system level adjustments without needing to use the terminal.
Tinkertool1.jpg
Tinkertool2.jpg

GetRealBro
 
  • Like
Reactions: strawbale

Spazturtle

macrumors member
Sep 17, 2013
43
24
thanks man but I am a total non techie and have never ventured into terminal.

I see now though that there is a check box for "use font smoothing when available" ... should this make any difference? Mine is checked by default.
You just copy and paste it into the terminal and press enter, it really isn't hard.
 

Morpheo

macrumors 65816
Feb 26, 2014
1,273
1,588
Paris/Montreal
No matter what you do, and yes I have run that terminal command that supposedly brings back subpixel AA, and I have played with the various font smoothing settings, here what you get in Logic Pro X preferences window for example:

Screen Shot 2018-11-08 at 10.59.24 AM.png


In High Sierra (and before) this was never an issue and text was perfectly readable. Not anymore.

Screen Shot 2018-11-08 at 11.21.10 AM.png


...I mean seriously? I like Mojave and I don't want to downgrade, but this is pretty lame. I can't believe no one at Apple noticed that during the last year when Mojave was in development.
 

SoCalReviews

macrumors 6502a
Dec 31, 2012
582
202
No matter what you do, and yes I have run that terminal command that supposedly brings back subpixel AA, and I have played with the various font smoothing settings, here what you get in Logic Pro X preferences window for example:

View attachment 802429

In High Sierra (and before) this was never an issue and text was perfectly readable. Not anymore.

View attachment 802433

...I mean seriously? I like Mojave and I don't want to downgrade, but this is pretty lame. I can't believe no one at Apple noticed that during the last year when Mojave was in development.
Agreed. This is REALLY lame. Apple should apply a fix for those who use non-retina screens... especially considering this falls under the category of an important "Accessibility" issue that could inhibit Mac owners with vision problems from being able to properly read certain text and therefore limit use of their Macs with Mojave OS installed.
 
Last edited:

puma1552

Suspended
Nov 20, 2008
5,559
1,945
Try turning LCD font smoothing OFF. I've had it on for the past ten years - until Mojave. Now fonts are thinner/crisper/sharper - noticably so - with it off, oddly enough. Turning that off reminds me of iOS 7 fonts.

As for non-retina displays, yeah it looks like garbage with font smoothing either on or off, unfortunately. So much so that I finally have my ACD listed on Craigslist. I mean it's still usable, sure, but it was already at a disadvantage compared to a retina screen displaying the same 1920 x 1200 resolution, and then the Mojave font crap just tanks it from there.
 

x34

macrumors 6502a
Oct 19, 2014
557
325
Try turning LCD font smoothing OFF. I've had it on for the past ten years - until Mojave. Now fonts are thinner/crisper/sharper - noticably so - with it off, oddly enough. Turning that off reminds me of iOS 7 fonts.
thanks, that does in fact look better with font smoothing off!
 

x34

macrumors 6502a
Oct 19, 2014
557
325
Better... but "crisp" or still soggy?
it's rather crisp, more like on ios devices. i also changed the system font to san francisco.

it's still different than on high sierra but well... sometimes the fonts are too small for my taste so i changed the minimum font size in safari from 9 to 12
 

0009827

Suspended
Jul 15, 2018
111
113
No matter what you do, and yes I have run that terminal command that supposedly brings back subpixel AA, and I have played with the various font smoothing settings, here what you get in Logic Pro X preferences window for example:

View attachment 802429

In High Sierra (and before) this was never an issue and text was perfectly readable. Not anymore.

View attachment 802433

...I mean seriously? I like Mojave and I don't want to downgrade, but this is pretty lame. I can't believe no one at Apple noticed that during the last year when Mojave was in development.
It *logic* does not look like that on my non retina screens. Only change I did was run terminal command. “Problem” solved.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.